aboutsummaryrefslogtreecommitdiffstats
path: root/net/miniupnpd
diff options
context:
space:
mode:
Diffstat (limited to 'net/miniupnpd')
-rw-r--r--net/miniupnpd/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index c617067108c3..0e2faa0a6f72 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -13,12 +13,11 @@ COMMENT= UPnP IGD implementation which uses pf/ipf
LICENSE= BSD3CLAUSE
-USES= cpe
+USES= cpe ssl
CPE_VENDOR= miniupnp_project
PLIST_FILES= etc/miniupnpd.conf.sample sbin/miniupnpd \
man/man8/miniupnpd.8.gz
MAKE_JOBS_UNSAFE=yes
-USE_OPENSSL= yes
USE_RC_SUBR= miniupnpd
CFLAGS+= -I${OPENSSLINC}
@@ -39,4 +38,8 @@ UPNP_IGDV2_EXTRA_PATCHES= ${PATCHDIR}/enable_igdv2.patch
UPNP_STRICT_EXTRA_PATCHES= ${PATCHDIR}/enable_upnp_strict.patch
LEASEFILE_EXTRA_PATCHES= ${PATCHDIR}/enable_leasefile.patch
+post-patch:
+ ${REINPLACE_CMD} -e 's|\(-lssl -lcrypto\)|$$(LDFLAGS) \1|g' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>