aboutsummaryrefslogtreecommitdiffstats
path: root/net/mono-zeroconf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mono-zeroconf/Makefile')
-rw-r--r--net/mono-zeroconf/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net/mono-zeroconf/Makefile b/net/mono-zeroconf/Makefile
new file mode 100644
index 000000000000..e6d4bc2310d3
--- /dev/null
+++ b/net/mono-zeroconf/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mono-zeroconf
+# Date created: Aug 27 2008
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mono-zeroconf
+PORTVERSION= 0.7.6
+CATEGORIES= net
+MASTER_SITES= http://download.banshee-project.org/${PORTNAME}/
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Cross platform Zero Configuration Networking library for Mono
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono \
+ ${LOCALBASE}/libdata/pkgconfig/avahi-sharp.pc:${PORTSDIR}/net/avahi-sharp
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= DOCS "Install documentation" on
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig gnomehack
+CONFIGURE_ARGS+= --program-transform-name="" \
+ --disable-mdnsresponder
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+
+.if !defined(WITHOUT_DOCS) && !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/monodocer:${PORTSDIR}/devel/monodoc
+CONFIGURE_ARGS+= --enable-docs
+.else
+CONFIGURE_ARGS+= --disable-docs
+.endif
+
+.include <bsd.port.post.mk>