aboutsummaryrefslogtreecommitdiffstats
path: root/net/mtr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mtr/Makefile')
-rw-r--r--net/mtr/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 3ae72b4aa4fe..fbc605a28086 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -11,9 +11,20 @@ CATEGORIES= net
MASTER_SITES= ftp://ftp.bitwizard.nl/mtr/ \
http://www.giovannelli.it/~gmarco/files/
+.if defined(USE_INET6)
+PATCHFILES= mtr-041-v6-20000113.diff.gz
+PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
+PATCH_DIST_STRIP= -p1
+.endif
+
MAINTAINER= billf@FreeBSD.org
HAS_CONFIGURE= yes
+.if defined(USE_INET6)
+CONFIGURE_ARGS+=--enable-ipv6
+.else
+CONFIGURE_ARGS+=--disable-ipv6
+.endif
MAN8= mtr.8
@@ -23,7 +34,7 @@ pre-patch:
@${ECHO} "If you want to compile with GTK support,"
@${ECHO} "hit Ctrl-C right now and use \"make USE_GTK=yes\" "
@${ECHO} ""
-CONFIGURE_ARGS=--with-gtk-prefix=/nopath
+CONFIGURE_ARGS+=--with-gtk-prefix=/nopath
.else
USE_XLIB= yes
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12