aboutsummaryrefslogtreecommitdiffstats
path: root/net/nam/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/nam/Makefile')
-rw-r--r--net/nam/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/nam/Makefile b/net/nam/Makefile
index 8810185c1f8f..5bf73e9c7fc5 100644
--- a/net/nam/Makefile
+++ b/net/nam/Makefile
@@ -27,6 +27,12 @@ CONFIGURE_ARGS= --with-tcl-ver=8.4 --with-tk-ver=8.4
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= # empty
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64"
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,friend Queue,friend class Queue,' ${WRKSRC}/queue.h
@@ -38,4 +44,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ex/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>