aboutsummaryrefslogtreecommitdiffstats
path: root/net/nemesis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/nemesis/Makefile')
-rw-r--r--net/nemesis/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/nemesis/Makefile b/net/nemesis/Makefile
index 30d67a8cda47..b34ccf3cf42e 100644
--- a/net/nemesis/Makefile
+++ b/net/nemesis/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nemesis
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= molter@tin.it
COMMENT= Command-line network packet creation and injection suite
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libnet-includes="${LOCALBASE}/include" \
@@ -27,4 +27,10 @@ MAN1= nemesis-arp.1 nemesis-dns.1 nemesis-ethernet.1 nemesis-icmp.1 \
nemesis-tcp.1 nemesis-udp.1 nemesis.1
PLIST_FILES= bin/nemesis
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>
800'>2013-09-201-0/+1 * - Make ports use the libc provided iconv implementation on 10-CURRENTmadpilot2013-09-051-1/+1 * - Add global options (DOCS, NLS, etc) to the OPTIONS_DEFINE and partly revert...makc2013-05-122-6/+3 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-271-2/+1 * - Convert my ports to new options frameworkmakc2012-07-27