aboutsummaryrefslogtreecommitdiffstats
path: root/net/netsaint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/netsaint/Makefile')
-rw-r--r--net/netsaint/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/net/netsaint/Makefile b/net/netsaint/Makefile
index 9edd7f45ff93..026e6f2b8433 100644
--- a/net/netsaint/Makefile
+++ b/net/netsaint/Makefile
@@ -37,6 +37,21 @@ CONFIGURE_ARGS= --with-command-user=netsaint \
--sysconfdir=${PREFIX}/etc/netsaint \
--localstatedir=${PREFIX}/var/netsaint
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-inc=${LOCALBASE}/include/mysql \
+ --with-mysql-xdata
+.endif
+
+.if defined(WITH_POSTGRES)
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
+ --with-pgsql-inc=${LOCALBASE}/pgsql \
+ --with-pgsql-xdata
+.endif
+
INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
pre-fetch: