aboutsummaryrefslogtreecommitdiffstats
path: root/net/nss-pam-ldapd
diff options
context:
space:
mode:
Diffstat (limited to 'net/nss-pam-ldapd')
-rw-r--r--net/nss-pam-ldapd/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net/nss-pam-ldapd/Makefile b/net/nss-pam-ldapd/Makefile
index fbe618fe7202..bbc37c492673 100644
--- a/net/nss-pam-ldapd/Makefile
+++ b/net/nss-pam-ldapd/Makefile
@@ -27,21 +27,24 @@ SUB_FILES+= pkg-message
NSLCD_PIDFILE?= /var/run/nslcd.pid
NSLCD_SOCKET?= /var/run/nslcd.ctl
+OPTIONS_DEFINE= KERBEROS
+OPTIONS_DEFAULT= KERBEROS
+
.if defined(SLAVE_PORT)
-OPTIONS_DEFINE= SASL
+OPTIONS_DEFINE+= SASL
OPTIONS_MULTI= MG1
OPTIONS_MULTI_MG1= PAM NSS
PAM_DESC= Build pam_ldap
NSS_DESC= Build nss support
SASL_DESC= Build sasl support
-OPTIONS_DEFAULT= PAM NSS
+OPTIONS_DEFAULT+= PAM NSS
CONFLICTS+= nss-pam-ldapd-[0-9]*
.else
OPTIONS_MULTI= MG1
OPTIONS_MULTI_MG1= PAM NSS
PAM_DESC= Build pam_ldap
NSS_DESC= Build nss support
-OPTIONS_DEFAULT= PAM NSS
+OPTIONS_DEFAULT+= PAM NSS
CONFLICTS+= nss-pam-ldapd-sasl-[0-9]*
.endif
@@ -65,6 +68,10 @@ PLIST_SUB+= CONFIG="${CONFIG_FILE}" \
NSS_LDAP_SHMAJOR="${NSS_LDAP_SHMAJOR}"
SUB_LIST+= CONFIG_FILE="${PREFIX}/etc/${CONFIG_FILE}"
+.if empty(PORT_OPTIONS:MKERBEROS)
+CONFIGURE_ARGS+= --disable-kerberos
+.endif
+
.if ${PORT_OPTIONS:MSASL}
WANT_OPENLDAP_SASL= yes
CONFIGURE_ARGS+= --enable-sasl