aboutsummaryrefslogtreecommitdiffstats
path: root/net/nss_ldap
diff options
context:
space:
mode:
Diffstat (limited to 'net/nss_ldap')
-rw-r--r--net/nss_ldap/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 222028eeb2f5..61ba5e93cdfb 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -23,6 +23,8 @@ USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:262 autoheader:262
USE_LDCONFIG= yes
USE_OPENLDAP= yes
+OPTIONS= LCLASS "Enable login classes via the loginClass attribute" on
+
PLIST_FILES= etc/nss_ldap.conf.sample \
lib/nss_ldap.so.1
@@ -41,6 +43,10 @@ MAN5= nss_ldap.5
CONFIGURE_ARGS+=--enable-configurable-krb5-ccname-env
.endif
+.if defined(WITH_LCLASS)
+CFLAGS+="-DHAVE_LOGIN_CLASSES"
+.endif
+
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}