aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ntop/Makefile')
-rw-r--r--net/ntop/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index 04dff5e3dc5c..4c62d7a6bca7 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -13,13 +13,13 @@ COMMENT= Network monitoring tool with command line and web interfaces
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm \
- libevent.so:${PORTSDIR}/devel/libevent2
-BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
- dot:${PORTSDIR}/graphics/graphviz \
- geoiplookup:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= libgdbm.so:databases/gdbm \
+ libevent.so:devel/libevent2
+BUILD_DEPENDS= rrdtool>=1.2:databases/rrdtool \
+ dot:graphics/graphviz \
+ geoiplookup:net/GeoIP
RUN_DEPENDS:= ${BUILD_DEPENDS} \
- urwfonts>0:${PORTSDIR}/x11-fonts/urwfonts
+ urwfonts>0:x11-fonts/urwfonts
DBDIR?= /var/db
@@ -50,11 +50,11 @@ XMLDUMP_DESC= Enable XML Dump support
JUMBO_FRAMES_DESC= Jumbo Frames (experimental)
MAKO_DESC= Install py-mako for Host Map, Region View
-PCAP_PORT_LIB_DEPENDS= libpcap.so.1:${PORTSDIR}/net/libpcap
+PCAP_PORT_LIB_DEPENDS= libpcap.so.1:net/libpcap
PCAP_PORT_CONFIGURE_ON= --with-pcap-root=${LOCALBASE}
PCAP_PORT_CONFIGURE_OFF=--with-pcap-root=/usr
-XMLDUMP_LIB_DEPENDS= libgdome.so:${PORTSDIR}/textproc/gdome2
+XMLDUMP_LIB_DEPENDS= libgdome.so:textproc/gdome2
XMLDUMP_CPPFLAGS= -I${LOCALBASE}/include/libxml2 \
-I${LOCALBASE}/include/libxml2/libxml \
-I${LOCALBASE}/include/libgdome \
@@ -64,7 +64,7 @@ XMLDUMP_CPPFLAGS= -I${LOCALBASE}/include/libxml2 \
# see http://www.cyberciti.biz/faq/freebsd-jumbo-frames-networking-configration/
JUMBO_FRAMES_CONFIGURE_ON= --enable-jumbo-frames
-MAKO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
+MAKO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mako>0:textproc/py-mako
pre-configure:
@(cd ${WRKSRC} && ./autogen.sh --noconfig)