aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntp-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ntp-devel/Makefile')
-rw-r--r--net/ntp-devel/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index fb40388cd3c5..43ee266cb81a 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ntp
-PORTVERSION= 4.2.5p155
+PORTVERSION= 4.2.5p156
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/ntp-dev/ \
http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-dev/ \
@@ -41,7 +41,27 @@ PLIST_SUB+= SSL=""
CONFIGURE_ARGS+= --enable-ipv6
.endif
-MAN1= ntp-keygen.1 ntpd.1 ntpdc.1 ntpq.1 ntpsnmpd.1 sntp.1
+MAN1= ntp-keygen.1 ntpd.1 ntpdc.1 ntpq.1 sntp.1
+
+pre-everything::
+ @${ECHO}
+ @${ECHO} If you wish to build this port with SNMP support, please make
+ @${ECHO} sure that the net-mgmt/net-snmp port is installed before
+ @${ECHO} building and installing this port.
+ @${ECHO}
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/net-snmp-config)
+# NTP autodects net-snmp and if found builds and installs a binary that
+# uses it. If detected, modify dependencies and package list.
+BUILD_DEPENDS= ${LOCALBASE}/bin/net-snmp-config:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS= netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
+MAN1+= ntpsnmpd.1
+PLIST_SUB+= NETSNMP=""
+.else
+PLIST_SUB+= NETSNMP="@comment "
+.endif
post-install:
@${MKDIR} ${EXAMPLESDIR}
@@ -53,4 +73,4 @@ post-install:
${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>