aboutsummaryrefslogtreecommitdiffstats
path: root/net/opal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/opal/Makefile')
-rw-r--r--net/opal/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index d63256ec0a30..1803aa0faf53 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= openh323
-PORTVERSION= 1.1pl1
+PORTVERSION= 1.2.12
CATEGORIES= net
MASTER_SITES= http://www.openh323.org/bin/ \
http://www.de.openh323.org/bin/ \
http://www.ru.openh323.org/bin/
-DISTFILES= openh323_1.1pl1.tar.gz \
- pwlib_min_1.1pl19.tar.gz
+DISTFILES= openh323_1.2.12.tar.gz \
+ pwlib_1.1.27.tar.gz
MAINTAINER= roger@freebsd.org
@@ -21,20 +21,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_NEWGCC= yes
USE_BISON= yes
-# If the user compiles with make -DNO_XWINDOWS do not include X support
-.if !defined(NO_XWINDOWS)
-USE_XLIB= yes
-.endif
-
USE_GMAKE= yes
ALL_TARGET= opt
MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib \
OPENH323DIR=${WRKDIR}/openh323
THE_MACHTYPE= ${ARCH:S/i386/x86/}
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
-.if defined(NO_XWINDOWS)
-MAKE_ARGS+= NO_XWINDOWS=1
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin