aboutsummaryrefslogtreecommitdiffstats
path: root/net/openh323
diff options
context:
space:
mode:
Diffstat (limited to 'net/openh323')
-rw-r--r--net/openh323/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index 7a6091918561..57767dc77f83 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -29,19 +29,15 @@ CPPFLAGS+= -I${LOCALBASE}/include -I${WRKSRC}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= BUILDTIME="YES"
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= FFMPEG SPEEX
+FFMPEG_LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
+FFMPEG_CONFIGURE_ON= --enable-rfc2190avcodec=${LOCALBASE}/include/ffmpeg
-.ifdef (WITH_FFMPEG)
-LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+= --enable-rfc2190avcodec=${LOCALBASE}/include/ffmpeg
-.endif
+SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
+SPEEX_CONFIGURE_ON= --enable-localspeex=no
+SPEEX_CONFIGURE_OFF= --enable-localspeex=yes
-.ifdef (WITH_SPEEX)
-LIB_DEPENDS+= libspeex.so:${PORTSDIR}/audio/speex
-CONFIGURE_ARGS+= --enable-localspeex=no
-.else
-CONFIGURE_ARGS+= --enable-localspeex=yes
-.endif
+.include <bsd.port.pre.mk>
.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "powerpc") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC