aboutsummaryrefslogtreecommitdiffstats
path: root/net/openntpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openntpd/Makefile')
-rw-r--r--net/openntpd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index 9e2623572ba9..562e30f49e54 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openntpd
-PORTVERSION= 20040714p
+PORTVERSION= 20040718p
CATEGORIES= net
MASTER_SITES= http://www.zip.com.au/~dtucker/openntpd/ \
http://dtucker.freeshell.org/openntpd/
@@ -15,12 +15,15 @@ MAINTAINER= naddy@FreeBSD.org
COMMENT= OpenBSD's Network Time Protocol daemon
USE_RC_SUBR= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
MAN5= ntpd.conf.5
MAN8= ntpd.8
pre-build:
+ ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
+ ${WRKSRC}/ntpd.conf.5 ${WRKSRC}/ntpd.8
@${SED} -e 's:%%PREFIX%%:${PREFIX}:g' \
-e 's:%%RC_SUBR%%:${RC_SUBR}:g' \
${FILESDIR}/openntpd.sh >${WRKDIR}/openntpd.sh