aboutsummaryrefslogtreecommitdiffstats
path: root/net/openvswitch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openvswitch/Makefile')
-rw-r--r--net/openvswitch/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 4879835b0155..61b14a3e9e32 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -15,10 +15,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= PERL=${PREFIX}/bin/perl \
SSL_CFLAGS="-I${OPENSSLINC}" \
SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
-USES= gmake pkgconfig
-USE_AUTOTOOLS= autoconf automake
+USES= autoreconf gmake pkgconfig python
USE_OPENSSL= yes
-USE_PYTHON= yes
USE_RC_SUBR= ovs-vswitchd ovsdb-server
OPTIONS_DEFINE= THREADED
@@ -30,12 +28,7 @@ THREADED_DESC= Experimental high-performance threading patch
CONFIGURE_ARGS+=--enable-threaded=yes
.endif
-AUTOTOOLSFILES= aclocal.m4
-
post-patch:
- @${REINPLACE_CMD} -e 's|1.11.3|%%AUTOMAKE_APIVER%%|g' \
- -e 's|2.68|%%AUTOCONF_VERSION%%|g' \
- ${WRKSRC}/aclocal.m4
.if ${PORT_OPTIONS:MTHREADED}
@# We can't use EXTRA_PATCHES, since we need to apply this one
@# after files/patch-bsd-netdef.diff, not before.