aboutsummaryrefslogtreecommitdiffstats
path: root/net/owncloud-csync/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/owncloud-csync/Makefile')
-rw-r--r--net/owncloud-csync/Makefile50
1 files changed, 0 insertions, 50 deletions
diff --git a/net/owncloud-csync/Makefile b/net/owncloud-csync/Makefile
deleted file mode 100644
index a78326169605..000000000000
--- a/net/owncloud-csync/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# Created by: arrowdodger <6yearold@gmail.com>
-# $FreeBSD$
-
-PORTNAME= owncloud-csync
-PORTVERSION= 0.91.4
-PORTREVISION= 2
-CATEGORIES= net kde
-MASTER_SITES= http://download.owncloud.com/desktop/stable/
-DISTNAME= ocsync-${PORTVERSION}
-
-MAINTAINER= 6yearold@gmail.com
-COMMENT= Csync fork for Owncloud
-
-LICENSE= GPLv2
-
-LIB_DEPENDS= libiniparser.so:${PORTSDIR}/devel/iniparser \
- libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient \
- libssh.so.4:${PORTSDIR}/security/libssh \
- libneon.so:${PORTSDIR}/www/neon
-
-USES= cmake:outsource iconv pkgconfig tar:bzip2
-USE_SQLITE= yes
-CMAKE_ARGS+= -DUNIT_TESTING=NO \
- -DMAN_INSTALL_DIR=${MANPREFIX}/man
-
-USE_LDCONFIG= yes
-
-DOCSDIR= ${PREFIX}/share/doc/ocsync
-ETCDIR= ${PREFIX}/etc/ocsync
-
-DEPRECATED= Merged into deskutils/mirall and unsupported upstream
-EXPIRATION_DATE= 2015-01-31
-
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
-
-post-patch:
- @${REINPLACE_CMD} -e 's/^add_subdirectory(doc)//' ${WRKSRC}/CMakeLists.txt
-.endif
-
-post-install:
-.for i in ocsync.conf ocsync_exclude.conf
- @${MV} ${STAGEDIR}${ETCDIR}/$i ${STAGEDIR}${ETCDIR}/$i.sample
-.endfor
-
-.include <bsd.port.mk>