aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Jaiku/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Net-Jaiku/Makefile')
-rw-r--r--net/p5-Net-Jaiku/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/p5-Net-Jaiku/Makefile b/net/p5-Net-Jaiku/Makefile
new file mode 100644
index 000000000000..18fc32a0ebb4
--- /dev/null
+++ b/net/p5-Net-Jaiku/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: Net::Jaiku
+# Date created: Jun 3, 2008
+# Whom: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Jaiku
+PORTVERSION= 0.0501
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A perl interface to jaiku.com's API
+
+RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ p5-JSON-Any>0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ p5-JSON-Any>0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Jaiku.3
+
+.include <bsd.port.mk>
2016-02-181-0/+1 * - Take Maintainershipmiwi2015-11-261-1/+1 * 1: add LICENSE.vanilla2015-02-251-1/+3 * Reset miwi's maintainership per his demandbapt2014-11-181-1/+1 * - Mark these ports as stage safemiwi2014-01-231-1/+0 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-211-5/+2 * - Update to 0.5.0miwi2012-05-172-4/+4 * At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450eadler2012-01-221-1/+1 * - Get Rid MD5 supportmiwi2011-03-191-1/+0 * - Update to 0.4.0miwi2009-10-102-4/+4 * - Take maintainershipmiwi2009-08-291-1/+1