aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Socket6
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-Socket6')
-rw-r--r--net/p5-Socket6/Makefile1
-rw-r--r--net/p5-Socket6/files/patch-Makefile.PL15
2 files changed, 16 insertions, 0 deletions
diff --git a/net/p5-Socket6/Makefile b/net/p5-Socket6/Makefile
index f8afeb69525f..b54ab7f0e6c7 100644
--- a/net/p5-Socket6/Makefile
+++ b/net/p5-Socket6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Socket6
PORTVERSION= 0.25
+PORTREVISION= 1
CATEGORIES= net perl5 ipv6
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR=CPAN:UMEMOTO
diff --git a/net/p5-Socket6/files/patch-Makefile.PL b/net/p5-Socket6/files/patch-Makefile.PL
new file mode 100644
index 000000000000..e64acda9da16
--- /dev/null
+++ b/net/p5-Socket6/files/patch-Makefile.PL
@@ -0,0 +1,15 @@
+Index: Makefile.PL
+diff -u Makefile.PL.orig Makefile.PL
+--- Makefile.PL.orig 2013-12-09 17:30:29.282987698 +0900
++++ Makefile.PL 2013-12-09 17:30:35.243986223 +0900
+@@ -101,3 +101,10 @@
+ close(OUT) || die "Failed to close file 'config.h' [$!]";
+ close(IN) || die "Failed to close file 'config.h.in' [$!]";
+ }
++
++package MY;
++sub install {
++ my $inherited = shift->SUPER::install(@_);
++ $inherited =~ s/(install :: (all )?pure_install) doc_install/$1/;
++ $inherited;
++}