aboutsummaryrefslogtreecommitdiffstats
path: root/net/pmacct/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/pmacct/Makefile')
-rw-r--r--net/pmacct/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/pmacct/Makefile b/net/pmacct/Makefile
index d15a2c4c1325..b9a42d04d3e3 100644
--- a/net/pmacct/Makefile
+++ b/net/pmacct/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pmacct
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.2
CATEGORIES= net
MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
@@ -26,12 +26,14 @@ GNU_CONFIGURE= yes
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${REINPLACE_CMD} -e \
- 's,<mysql/mysql.h>,<mysql.h>,' \
- ${WRKSRC}/mysql_plugin.h
+ @${REINPLACE_CMD} -e \
+ 's,<mysql/mysql.h>,<mysql.h>,' \
+ ${WRKSRC}/mysql_plugin.h
+ @${REINPLACE_CMD} -e \
+ 's|-O2|${CFLAGS}|g' ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)