aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-samba/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-samba/Makefile')
-rw-r--r--net/py-samba/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/net/py-samba/Makefile b/net/py-samba/Makefile
new file mode 100644
index 000000000000..7047d267e91c
--- /dev/null
+++ b/net/py-samba/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: samba-python
+# Date created: 01 May 2004
+# Whom: Timur Bakeyev <timur@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PORTEPOCH= 0
+CATEGORIES= net python
+PKGNAMEPREFIX= py-
+
+COMMENT= Python bindings for Samba
+
+CONFLICTS=
+
+SAMBA_PORT= samba-devel
+SAMBA_SUBPORT= yes
+
+MASTERDIR= ${.CURDIR}/../${SAMBA_PORT}
+PKGDIR= ${.CURDIR}
+
+USE_PYTHON= 2.1+
+USE_PYDISTUTILS= yes
+PYSETUP= python/setup.py
+
+CONFIGURE_ARGS+= --with-python
+# This is taken from SAMBA_PORT(grep without)
+CONFIGURE_ARGS+= --disable-cups
+CONFIGURE_ARGS+= --without-libsmbclient
+CONFIGURE_ARGS+= --without-syslog
+CONFIGURE_ARGS+= --without-quotas
+CONFIGURE_ARGS+= --without-utmp
+CONFIGURE_ARGS+= --without-winbind
+CONFIGURE_ARGS+= --without-ldapsam
+CONFIGURE_ARGS+= --without-pam_smbpass
+
+do-build:
+ cd ${WRKSRC} && ${MAKE} proto
+ cd ${WRKSRC} && ${MAKE} python_ext
+
+post-install:
+ -@${MKDIR} ${EXAMPLESDIR}
+ @${CP} -Rp ${WRKSRC}/python/examples/* ${EXAMPLESDIR}
+
+.include "${MASTERDIR}/Makefile"