aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-twitter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-twitter/Makefile')
-rw-r--r--net/py-twitter/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/py-twitter/Makefile b/net/py-twitter/Makefile
new file mode 100644
index 000000000000..465face2abd2
--- /dev/null
+++ b/net/py-twitter/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: py-twitter
+# Date created: Apr 13, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= twitter
+PORTVERSION= 0.3
+CATEGORIES= net python
+MASTER_SITES= http://python-twitter.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= A python wrapper around the Twitter API
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>0:${PORTSDIR}/devel/py-simplejson
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PYTWITTER_EGG= python_${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+PLIST_SUB+= PYTWITTER_EGG=${PYTWITTER_EGG}
+
+.include <bsd.port.mk>