aboutsummaryrefslogtreecommitdiffstats
path: root/net/qtella/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/qtella/Makefile')
-rw-r--r--net/qtella/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/qtella/Makefile b/net/qtella/Makefile
index 9c748919beea..b88b85b878c3 100644
--- a/net/qtella/Makefile
+++ b/net/qtella/Makefile
@@ -6,23 +6,27 @@
#
PORTNAME= qtella
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.3
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qtella
MAINTAINER= jon@witchspace.com
-USE_KDELIBS_VER= 2
HAS_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS+= --with-qt-dir=${X11BASE} --with-qt-moc=${X11BASE}/bin
CONFIGURE_ENV+= LDFLAGS=-pthread CXXFLAGS="${CXXFLAGS} -pthread"
-MAKE_ENV+= MOC=${X11BASE}/bin/moc2
MAKE_ARGS+= -j2
+.if defined(USE_KDE2)
+USE_KDELIBS_VER= 2
+MAKE_ENV+= MOC=${X11BASE}/bin/moc2
pre-patch:
@${PERL} -pi.orig -e 's|/moc(\W)|/moc2\1|g' \
${WRKSRC}/configure ${WRKSRC}/src/Makefile.in
+.else
+USE_KDELIBS_VER=3
+.endif
.include <bsd.port.mk>