aboutsummaryrefslogtreecommitdiffstats
path: root/net/rsync
diff options
context:
space:
mode:
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile1
-rw-r--r--net/rsync/files/patch-clientserver.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 4cd3799ea4cb..c7160f8971a9 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rsync
PORTVERSION= 2.6.7
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://rsync.samba.org/ftp/%SUBDIR%/ \
ftp://ftp.samba.org//pub/%SUBDIR%/ \
diff --git a/net/rsync/files/patch-clientserver.c b/net/rsync/files/patch-clientserver.c
new file mode 100644
index 000000000000..ecf19800c696
--- /dev/null
+++ b/net/rsync/files/patch-clientserver.c
@@ -0,0 +1,20 @@
+--- clientserver.c 24 Feb 2006 01:56:26 -0000 1.177
++++ clientserver.c 31 Mar 2006 17:36:26 -0000
+@@ -733,8 +733,6 @@ int start_daemon(int f_in, int f_out)
+ char *host = client_name(f_in);
+ int i;
+
+- rprintf(FLOG, "connect from %s (%s)\n", host, addr);
+-
+ io_set_sock_fds(f_in, f_out);
+
+ if (!lp_load(config_file, 0))
+@@ -742,6 +740,8 @@ int start_daemon(int f_in, int f_out)
+
+ log_init();
+
++ rprintf(FLOG, "connect from %s (%s)\n", host, addr);
++
+ if (!am_server) {
+ set_socket_options(f_in, "SO_KEEPALIVE");
+ if (sockopts)