aboutsummaryrefslogtreecommitdiffstats
path: root/net/ruby-spread/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ruby-spread/Makefile')
-rw-r--r--net/ruby-spread/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/net/ruby-spread/Makefile b/net/ruby-spread/Makefile
deleted file mode 100644
index c150d861ca3c..000000000000
--- a/net/ruby-spread/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: ruby-spread
-# Date created: 2002 July 22
-# Whom: seanc@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= spread
-PORTVERSION= 1.0
-CATEGORIES= net ruby
-MASTER_SITES= http://www.omniti.com/~george/rb_spread/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= rb_${PORTNAME}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Ruby interface to the Spread library
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-LIB_DEPENDS= tspread.1:${PORTSDIR}/net/spread
-
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}-${PORTVERSION}
-
-INSTALL_TARGET= site-install
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/flooder.rb ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/user.rb ${RUBY_MODEXAMPLESDIR}
- ${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>