aboutsummaryrefslogtreecommitdiffstats
path: root/net/samba3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/samba3/Makefile')
-rw-r--r--net/samba3/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index c70a7a372206..84e9c9b41bc4 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= samba
-PORTVERSION= 2.0.6
+PORTVERSION= 2.0.7
CATEGORIES= net
MASTER_SITES= ftp://ftp.samba.org/pub/samba/ \
ftp://ring.asahi-net.or.jp/pub/net/samba/ \
@@ -32,6 +32,7 @@ SAMPLE_CONFIG= ${SAMBA_CONFDIR}/smb.conf.default
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
--localstatedir=${VARDIR} --with-swatdir=${PREFIX}/share/swat \
+ --with-sambabook=${PREFIX}/share/swat/using_samba \
--with-lockdir=${VARDIR}/spool/lock --with-privatedir=${SAMBA_PRIVATE}
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
@@ -95,7 +96,9 @@ post-install:
for i in faq htmldocs textdocs yodldocs ; do \
${MKDIR} ${PREFIX}/share/doc/samba/$$i ; \
for j in ${WRKDIR}/${DISTNAME}/docs/$$i/* ; do \
- ${INSTALL_DATA} $$j ${PREFIX}/share/doc/samba/$$i ;\
+ if [ $$j != ${WRKDIR}/${DISTNAME}/docs/htmldocs/using_samba ] ; then \
+ ${INSTALL_DATA} $$j ${PREFIX}/share/doc/samba/$$i ;\
+ fi; \
done \
done
${MKDIR} ${PREFIX}/share/doc/samba