aboutsummaryrefslogtreecommitdiffstats
path: root/net/sipxregistry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/sipxregistry/Makefile')
-rw-r--r--net/sipxregistry/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net/sipxregistry/Makefile b/net/sipxregistry/Makefile
new file mode 100644
index 000000000000..073255c6107e
--- /dev/null
+++ b/net/sipxregistry/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: sipxregistry
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxregistry
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX server for handling SIP UA registrations
+
+BUILD_DEPENDS= ginstall:${PORTSDIR}/sysutils/coreutils \
+ cppunit-config:${PORTSDIR}/devel/cppunit
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ sipXtack:${PORTSDIR}/net/sipxtacklib \
+ sipXcommserver:${PORTSDIR}/net/sipxcommserverlib \
+ pcre.0:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
+SUB_FILES= pkg-deinstall
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipregistrar.sh.in
+
+.include <bsd.port.mk>