aboutsummaryrefslogtreecommitdiffstats
path: root/net/sipxregistry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/sipxregistry/Makefile')
-rw-r--r--net/sipxregistry/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/net/sipxregistry/Makefile b/net/sipxregistry/Makefile
index 073255c6107e..b89506040378 100644
--- a/net/sipxregistry/Makefile
+++ b/net/sipxregistry/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipxregistry
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
@@ -32,10 +33,20 @@ CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
CONFIGURE_ARGS+= --enable-sip-tls \
--prefix=${PREFIX} \
--localstatedir=${LOCALSTATEDIR}
-SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
-SUB_FILES= pkg-deinstall
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR} \
+ PREFIX=${PREFIX}
+SUB_FILES= pkg-install pkg-deinstall
+PKGINSTALL= ${WRKDIR}/pkg-install
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipregistrar.sh.in
+pre-install:
+
+pre-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
.include <bsd.port.mk>