aboutsummaryrefslogtreecommitdiffstats
path: root/net/sipxvxml
diff options
context:
space:
mode:
Diffstat (limited to 'net/sipxvxml')
-rw-r--r--net/sipxvxml/Makefile13
-rw-r--r--net/sipxvxml/files/pkg-install.in38
2 files changed, 49 insertions, 2 deletions
diff --git a/net/sipxvxml/Makefile b/net/sipxvxml/Makefile
index 779225817b42..0c146444d5f5 100644
--- a/net/sipxvxml/Makefile
+++ b/net/sipxvxml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipxvxml
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
@@ -34,10 +35,18 @@ CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
CONFIGURE_ARGS+= --enable-sip-tls \
--prefix=${PREFIX} \
--localstatedir=${LOCALSTATEDIR}
-SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
-SUB_FILES= pkg-deinstall
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR} \
+ PREFIX=${PREFIX}
+SUB_FILES= pkg-install pkg-deinstall
+PKGINSTALL= ${WRKDIR}/pkg-install
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipXvxml.sh.in
+pre-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
.include <bsd.port.mk>
diff --git a/net/sipxvxml/files/pkg-install.in b/net/sipxvxml/files/pkg-install.in
new file mode 100644
index 000000000000..be5585a14288
--- /dev/null
+++ b/net/sipxvxml/files/pkg-install.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin
+
+USER=sipx
+GROUP=sipx
+
+case $2 in
+PRE-INSTALL)
+ if pw group show "${GROUP}" 2> /dev/null ; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if pw groupadd ${GROUP} ; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Add of group \"${GROUP}\" failed."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${USER}" 2> /dev/null ; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if pw useradd ${USER} -g ${GROUP} -h - \
+ -d %%LOCALSTATEDIR%%/sipxdata/configserver/phone/profile/tftproot -s %%PREFIX%%/bin/bash -c "sipX" ; then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Add of user \"${USER}\" failed."
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ chown ${USER}:${GROUP} %%PREFIX%%/etc/sipxpbx
+ chown ${USER}:${GROUP} %%PREFIX%%/www/sipX/conf
+ chown ${USER}:${GROUP} %%PREFIX%%/www/sipX
+ ;;
+esac