aboutsummaryrefslogtreecommitdiffstats
path: root/net/ssldump
diff options
context:
space:
mode:
Diffstat (limited to 'net/ssldump')
-rw-r--r--net/ssldump/Makefile24
-rw-r--r--net/ssldump/distinfo1
-rw-r--r--net/ssldump/pkg-comment1
-rw-r--r--net/ssldump/pkg-descr8
-rw-r--r--net/ssldump/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/net/ssldump/Makefile b/net/ssldump/Makefile
new file mode 100644
index 000000000000..01c6c8142e27
--- /dev/null
+++ b/net/ssldump/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ssldump
+# Date created: 10 November 2000
+# Whom: Kris Kennaway <kris@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssldump
+PORTVERSION= 0.9b1
+CATEGORIES= net security
+MASTER_SITES= http://www.rtfm.com/ssldump/
+
+MAINTAINER= kris@FreeBSD.org
+
+USE_OPENSSL= YES
+
+.include <bsd.port.pre.mk>
+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE}
+
+MAN1= ssldump.1
+
+.include <bsd.port.post.mk>
diff --git a/net/ssldump/distinfo b/net/ssldump/distinfo
new file mode 100644
index 000000000000..5d45250d2160
--- /dev/null
+++ b/net/ssldump/distinfo
@@ -0,0 +1 @@
+MD5 (ssldump-0.9b1.tar.gz) = ace8f1b4f8bfa4cd494a3e546655c5e7
diff --git a/net/ssldump/pkg-comment b/net/ssldump/pkg-comment
new file mode 100644
index 000000000000..b25b5eaa717a
--- /dev/null
+++ b/net/ssldump/pkg-comment
@@ -0,0 +1 @@
+ssldump is an SSLv3/TLS network protocol analyzer.
diff --git a/net/ssldump/pkg-descr b/net/ssldump/pkg-descr
new file mode 100644
index 000000000000..688abce3dc93
--- /dev/null
+++ b/net/ssldump/pkg-descr
@@ -0,0 +1,8 @@
+ssldump is an SSLv3/TLS network protocol analyzer. It identifies TCP
+connections on the chosen network interface and attempts to interpret
+them as SSLv3/TLS traffic. When it identifies SSLv3/TLS traffic, it
+decodes the records and displays them in a textual form to stdout. If
+provided with the appropriate keying material, it will also decrypt
+the connections and display the application data traffic.
+
+WWW: http://www.rtfm.com/ssldump/
diff --git a/net/ssldump/pkg-plist b/net/ssldump/pkg-plist
new file mode 100644
index 000000000000..dbb1bdc0d110
--- /dev/null
+++ b/net/ssldump/pkg-plist
@@ -0,0 +1 @@
+bin/ssldump