aboutsummaryrefslogtreecommitdiffstats
path: root/net/syncthing-discosrv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/syncthing-discosrv/Makefile')
-rw-r--r--net/syncthing-discosrv/Makefile30
1 files changed, 12 insertions, 18 deletions
diff --git a/net/syncthing-discosrv/Makefile b/net/syncthing-discosrv/Makefile
index 0b4ff3650fac..f74a03395ea9 100644
--- a/net/syncthing-discosrv/Makefile
+++ b/net/syncthing-discosrv/Makefile
@@ -5,11 +5,6 @@ PORTNAME= syncthing-discosrv
PORTVERSION= 0.0.0.2015022401
PORTREVISION= 3
CATEGORIES= net
-MASTER_SITES= https://github.com/syncthing/syncthing/archive/v${SYNCTHING_VER}.tar.gz?dummy=/:group2 \
- https://codeload.github.com/golang/groupcache/legacy.tar.gz/${GROUPCACHE_COMMIT}?dummy=/:group3
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- syncthing-${SYNCTHING_VER}${EXTRACT_SUFX}:group2 \
- golang-groupcache-${GROUPCACHE_COMMIT}${EXTRACT_SUFX}:group3
MAINTAINER= swills@FreeBSD.org
COMMENT= Discovery server for syncthing
@@ -17,12 +12,11 @@ COMMENT= Discovery server for syncthing
BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
USE_GITHUB= yes
-GH_ACCOUNT= syncthing
-GH_PROJECT= discosrv
-GH_TAGNAME= 4e1240a610bcc2ef8772eb2641492822b4ec4f88
+GH_ACCOUNT= syncthing golang:gc
+GH_PROJECT= discosrv syncthing:st groupcache:gc
+GH_TAGNAME= 4e1240a v${SYNCTHING_VER}:st d2a1805:gc
SYNCTHING_VER= 0.11.5
-GROUPCACHE_COMMIT= d2a1805
PLIST_FILES= bin/syncthing-discosrv
@@ -40,25 +34,25 @@ post-patch:
@${MKDIR} ${WRKSRC}/src/github.com/syncthing
@${MKDIR} ${WRKSRC}/src/github.com/syndtr
@${MKDIR} ${WRKSRC}/src/golang.org/x
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER}/Godeps/_workspace/src/github.com/calmh \
+ @${MV} ${WRKSRC_st}/Godeps/_workspace/src/github.com/calmh \
${WRKSRC}/src/github.com
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER}/Godeps/_workspace/src/github.com/bkaradzic/go-lz4 \
+ @${MV} ${WRKSRC_st}/Godeps/_workspace/src/github.com/bkaradzic/go-lz4 \
${WRKSRC}/src/github.com/bkaradzic
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER}/Godeps/_workspace/src/github.com/juju/ratelimit \
+ @${MV} ${WRKSRC_st}/Godeps/_workspace/src/github.com/juju/ratelimit \
${WRKSRC}/src/github.com/juju
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER}/Godeps/_workspace/src/github.com/syndtr/goleveldb \
+ @${MV} ${WRKSRC_st}/Godeps/_workspace/src/github.com/syndtr/goleveldb \
${WRKSRC}/src/github.com/syndtr
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER}/Godeps/_workspace/src/github.com/syndtr/gosnappy \
+ @${MV} ${WRKSRC_st}/Godeps/_workspace/src/github.com/syndtr/gosnappy \
${WRKSRC}/src/github.com/syndtr
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER}/Godeps/_workspace/src/golang.org/x/crypto \
+ @${MV} ${WRKSRC_st}/Godeps/_workspace/src/golang.org/x/crypto \
${WRKSRC}/src/golang.org/x
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER}/Godeps/_workspace/src/golang.org/x/text \
+ @${MV} ${WRKSRC_st}/Godeps/_workspace/src/golang.org/x/text \
${WRKSRC}/src/golang.org/x
- @${MV} ${WRKDIR}/syncthing-${SYNCTHING_VER} \
+ @${MV} ${WRKSRC_st} \
${WRKSRC}/src/github.com/syncthing/syncthing
@${MV} ${WRKSRC}/src/github.com/syncthing/syncthing/Godeps/_workspace/src/github.com/syncthing/protocol \
${WRKSRC}/src/github.com/syncthing/protocol
- @${MV} ${WRKDIR}/golang-groupcache-${GROUPCACHE_COMMIT} \
+ @${MV} ${WRKSRC_gc} \
${WRKSRC}/src/github.com/golang/groupcache
do-build: