aboutsummaryrefslogtreecommitdiffstats
path: root/net/tcptraceroute-devel
diff options
context:
space:
mode:
Diffstat (limited to 'net/tcptraceroute-devel')
-rw-r--r--net/tcptraceroute-devel/Makefile10
-rw-r--r--net/tcptraceroute-devel/files/patch-Makefile6
2 files changed, 11 insertions, 5 deletions
diff --git a/net/tcptraceroute-devel/Makefile b/net/tcptraceroute-devel/Makefile
index b1aa9cd585d3..85a40f770c37 100644
--- a/net/tcptraceroute-devel/Makefile
+++ b/net/tcptraceroute-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcptraceroute
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://michael.toren.net/code/tcptraceroute/ \
http://sunpoet.net/distfiles/
@@ -15,10 +15,16 @@ MASTER_SITES= http://michael.toren.net/code/tcptraceroute/ \
MAINTAINER= sunpoet@sunpoet.net
COMMENT= A traceroute implementation using TCP packets
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
MAN8= tcptraceroute.8
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
+
post-install:
@${CHMOD} u+s ${PREFIX}/sbin/tcptraceroute
diff --git a/net/tcptraceroute-devel/files/patch-Makefile b/net/tcptraceroute-devel/files/patch-Makefile
index 6564b05352a2..f137ff657f9d 100644
--- a/net/tcptraceroute-devel/files/patch-Makefile
+++ b/net/tcptraceroute-devel/files/patch-Makefile
@@ -9,8 +9,8 @@
-DESTDIR=/usr/local/bin
+CC?= cc
+CFLAGS?= -O -pipe -Wall
-+LNETINC= -I${LOCALBASE}/include
-+LNETLIB= -L${LOCALBASE}/lib
++LNETINC= `libnet-config --cflags`
++LNETLIB= `libnet-config --libs`
+
+BINDIR= ${PREFIX}/sbin
+MANDIR= ${PREFIX}/man
@@ -22,7 +22,7 @@
+ $(CC) $(CFLAGS) `libnet-config --defines` $(LNETINC) \
-o tcptraceroute tcptraceroute.c \
- `libnet-config --libs` -lpcap
-+ $(LNETLIB) `libnet-config --libs` -lpcap
++ $(LNETLIB) -lpcap
static:
$(MAKE) tcptraceroute CFLAGS="$(CFLAGS) -static"