aboutsummaryrefslogtreecommitdiffstats
path: root/net/tdetect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/tdetect/Makefile')
-rw-r--r--net/tdetect/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/net/tdetect/Makefile b/net/tdetect/Makefile
index ce448bea41c0..2a541b207bdd 100644
--- a/net/tdetect/Makefile
+++ b/net/tdetect/Makefile
@@ -1,30 +1,29 @@
-# New ports collection makefile for: tdetect
-# Date created: Sun Jan 31, 1997
-# Whom: shipley@dis.org
-#
+# Created by: shipley@dis.org
# $FreeBSD$
-#
PORTNAME= tdetect
PORTVERSION= 0.2
CATEGORIES= net
-MASTER_SITES= # disappeared
+MASTER_SITES= PACKETSTORM/UNIX/loggers
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility for detecting traceroutes and reporting them via syslog
+PLIST_FILES= sbin/tdetect etc/rc.d/tdetect.sh
+SUB_FILES= pkg-message
+
pre-configure:
- ${REINPLACE_CMD} -e 's/trdetect/tdetect/g' ${WRKSRC}/config.h
- ${REINPLACE_CMD} -e 's/LOG_AUTHPRIV/LOG_SECURITY/g' ${WRKSRC}/config.h
+ @${REINPLACE_CMD} -e 's/trdetect/tdetect/g' ${WRKSRC}/config.h
+ @${REINPLACE_CMD} -e 's/LOG_AUTHPRIV/LOG_SECURITY/g' ${WRKSRC}/config.h
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tdetect ${PREFIX}/sbin/tdetect
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/tdetect.sh ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/tdetect.sh startup file."; \
+ ${ECHO_MSG} "Installing ${PREFIX}/etc/rc.d/tdetect.sh startup file."; \
${INSTALL_SCRIPT} -m 750 ${FILESDIR}/tdetect.sh ${PREFIX}/etc/rc.d/tdetect.sh; \
- ${SED} -e 's,/usr/local,${PREFIX},g' ${PKGMESSAGE}; \
+ ${CAT} ${PKGMESSAGE}; \
fi
.include <bsd.port.mk>