aboutsummaryrefslogtreecommitdiffstats
path: root/net/tftpgrab
diff options
context:
space:
mode:
Diffstat (limited to 'net/tftpgrab')
-rw-r--r--net/tftpgrab/Makefile21
-rw-r--r--net/tftpgrab/distinfo3
-rw-r--r--net/tftpgrab/files/patch-Makefile.in13
-rw-r--r--net/tftpgrab/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/net/tftpgrab/Makefile b/net/tftpgrab/Makefile
new file mode 100644
index 000000000000..ddb4bc6d8112
--- /dev/null
+++ b/net/tftpgrab/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: tftpgrab
+# Date created: 21 Sep 2007
+# Whom: Wesley Shields <wxs@atarininja.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tftpgrab
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://pseudo-flaw.net/tftpgrab/ \
+ http://www.atarininja.org/~wxs/distfiles/
+
+MAINTAINER= wxs@atarininja.org
+COMMENT= TFTP stream extractor
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/tftpgrab
+
+.include <bsd.port.mk>
diff --git a/net/tftpgrab/distinfo b/net/tftpgrab/distinfo
new file mode 100644
index 000000000000..4633d394f144
--- /dev/null
+++ b/net/tftpgrab/distinfo
@@ -0,0 +1,3 @@
+MD5 (tftpgrab-0.2.tar.gz) = 4c42995a50557f4ff3cd930672811554
+SHA256 (tftpgrab-0.2.tar.gz) = eb6309a23a6be83291659e7f5731dbc82e121f9ef9c4c4c7014e0c0a1af1e367
+SIZE (tftpgrab-0.2.tar.gz) = 109852
diff --git a/net/tftpgrab/files/patch-Makefile.in b/net/tftpgrab/files/patch-Makefile.in
new file mode 100644
index 000000000000..5549c65bda1f
--- /dev/null
+++ b/net/tftpgrab/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- ./Makefile.in.orig 2007-09-21 18:12:03.000000000 -0400
++++ ./Makefile.in 2007-09-21 18:12:25.000000000 -0400
+@@ -237,8 +237,8 @@
+ if test -f $$p \
+ ; then \
+ f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
+- echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
+- $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
++ echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$p'"; \
++ $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$p" || exit 1; \
+ else :; fi; \
+ done
+
diff --git a/net/tftpgrab/pkg-descr b/net/tftpgrab/pkg-descr
new file mode 100644
index 000000000000..2661a308a1ec
--- /dev/null
+++ b/net/tftpgrab/pkg-descr
@@ -0,0 +1,4 @@
+A TFTP stream extractor. It reads in a pcap file and attempts to
+reconstruct the files transfered via TFTP.
+
+WWW: http://pseudo-flaw.net/tftpgrab/