aboutsummaryrefslogtreecommitdiffstats
path: root/net/unison232
diff options
context:
space:
mode:
Diffstat (limited to 'net/unison232')
-rw-r--r--net/unison232/Makefile10
-rw-r--r--net/unison232/files/unison.desktop.in11
-rw-r--r--net/unison232/pkg-plist4
3 files changed, 24 insertions, 1 deletions
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index bf456f4184da..d9b5049cb17c 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -7,22 +7,26 @@
PORTNAME= unison
PORTVERSION= 2.32.52
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
-MAINTAINER= daniel+unison@pelleg.org
+MAINTAINER= mad@madpilot.net
COMMENT= A user-level file synchronization tool
PLIST_SUB= PORTVERSION=${PORTVERSION}
USE_GMAKE= yes
+WANT_GNOME= yes
MAKE_ARGS= CFLAGS=""
CONFLICTS= unison-devel-[0-9]* unison-nox11-[0-9]*
MAKE_JOBS_UNSAFE= yes
+LICENCE= GPLv3
+
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
@@ -43,6 +47,8 @@ BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
PATCH_DEPENDS+= ${BUILD_DEPENDS}
CONFLICTS+= ocaml-nox11*
+USE_GNOME= desktopfileutils
+SUB_FILES+= ${PORTNAME}.desktop
.else
MAKE_ARGS+= UISTYLE=text
PLIST_SUB+= TEXT="@comment "
@@ -68,6 +74,8 @@ post-install:
.endif
.if defined(WITH_GTK2)
@${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.desktop ${DESKTOPDIR}
+ @-update-desktop-database > /dev/null
@${CAT} ${PKGMESSAGE}
.else
@${CAT} ${PKGMESSAGE}.nox11
diff --git a/net/unison232/files/unison.desktop.in b/net/unison232/files/unison.desktop.in
new file mode 100644
index 000000000000..9a85315843f7
--- /dev/null
+++ b/net/unison232/files/unison.desktop.in
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Unison
+GenericName=File-synchronization tool
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=GTK;Utility;
+Exec=unison
+Comment=Synchronize files (directories) over different disks (hosts)
+Comment[ru]=Синхронизация файлов (каталогов) на нескольких дисках (компьютерах)
diff --git a/net/unison232/pkg-plist b/net/unison232/pkg-plist
index 7fc5e3d995b4..a7e19c203c90 100644
--- a/net/unison232/pkg-plist
+++ b/net/unison232/pkg-plist
@@ -1,4 +1,5 @@
bin/unison
+%%TEXT%%share/applications/unison.desktop
%%TEXT%%bin/unison-text
%%PORTDOCS%%%%DOCSDIR%%/BUGS.txt
%%PORTDOCS%%%%DOCSDIR%%/NEWS
@@ -7,3 +8,6 @@ bin/unison
%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.pdf
%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.ps
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%TEXT%%@dirrmtry share/applications
+%%TEXT%%@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || :
+%%TEXT%%@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || :