aboutsummaryrefslogtreecommitdiffstats
path: root/net/vyqchat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/vyqchat/Makefile')
-rw-r--r--net/vyqchat/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net/vyqchat/Makefile b/net/vyqchat/Makefile
new file mode 100644
index 000000000000..5a04afc65c71
--- /dev/null
+++ b/net/vyqchat/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: vyqchat
+# Date created: 25 August 2005
+# Whom: vic_semionov
+#
+# $FreeBSD$
+#
+
+PORTNAME= vyqchat
+PORTVERSION= 0.2.8
+CATEGORIES= net
+MASTER_SITES= http://linux.bydg.org/~yogin/
+
+MAINTAINER= semionov@mail.bg
+COMMENT= A Qt LAN chat, compatible with Vypress Chat
+
+USE_QT_VER= 3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+QTCFGLIBS= ${PTHREAD_LIBS}
+
+CONFIGURE_ARGS= --with-Qt-dir=${QT_PREFIX}
+
+.if !defined(WITHOUT_ARTS)
+LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
+.else
+CONFIGURE_ARGS+=--without-arts
+.endif
+
+.if defined(WITH_LIBAO)
+LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+.else
+CONFIGURE_ARGS+=--without-libao
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>