aboutsummaryrefslogtreecommitdiffstats
path: root/net/x11vnc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/x11vnc/Makefile')
-rw-r--r--net/x11vnc/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 7c86ec725978..7c75fa715e6d 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= x11vnc
-PORTVERSION= 0.8.3
-PORTREVISION= 1
+PORTVERSION= 0.9.3
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR=libvncserver
@@ -25,18 +24,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= x11vnc.1
-DOCS= AUTHORS COPYING ChangeLog NEWS README README.LibVNCServer TODO
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README README.LibVNCServer TODO
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
-.ifndef (NOPORTDOCS)
+.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
-.for i in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
.endif
.include <bsd.port.mk>