aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile5
-rw-r--r--net/ruby-mpi/Makefile55
-rw-r--r--net/ruby-mpi/distinfo2
-rw-r--r--net/ruby-mpi/files/patch-configure13
-rw-r--r--net/ruby-mpi/pkg-descr16
-rw-r--r--net/ruby-mpi/pkg-plist38
-rw-r--r--net/ruby-nis/Makefile45
-rw-r--r--net/ruby-nis/distinfo2
-rw-r--r--net/ruby-nis/files/patch-extconf.rb13
-rw-r--r--net/ruby-nis/files/patch-yp.c10
-rw-r--r--net/ruby-nis/pkg-descr4
-rw-r--r--net/ruby-nis/pkg-plist9
-rw-r--r--net/ruby-pcap/Makefile45
-rw-r--r--net/ruby-pcap/distinfo2
-rw-r--r--net/ruby-pcap/files/patch-Pcap.c15
-rw-r--r--net/ruby-pcap/pkg-descr8
-rw-r--r--net/ruby-pcap/pkg-plist40
-rw-r--r--net/ruby-romp/Makefile60
-rw-r--r--net/ruby-romp/distinfo3
-rw-r--r--net/ruby-romp/pkg-descr21
-rw-r--r--net/ruby-romp/pkg-plist7
-rw-r--r--net/ruby-spread/Makefile43
-rw-r--r--net/ruby-spread/distinfo2
-rw-r--r--net/ruby-spread/files/patch-extconf.rb9
-rw-r--r--net/ruby-spread/pkg-descr3
-rw-r--r--net/ruby-spread/pkg-plist6
26 files changed, 0 insertions, 476 deletions
diff --git a/net/Makefile b/net/Makefile
index 8b6e445a2378..7304e2acef1b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -944,12 +944,7 @@
SUBDIR += ruby-dict
SUBDIR += ruby-icmp
SUBDIR += ruby-ldap
- SUBDIR += ruby-mpi
SUBDIR += ruby-net-geoip
- SUBDIR += ruby-nis
- SUBDIR += ruby-pcap
- SUBDIR += ruby-romp
- SUBDIR += ruby-spread
SUBDIR += ruby-tcpsocketpipe
SUBDIR += ruby-tserver
SUBDIR += rubygem-amqp
diff --git a/net/ruby-mpi/Makefile b/net/ruby-mpi/Makefile
deleted file mode 100644
index 4e75fef5551f..000000000000
--- a/net/ruby-mpi/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# New ports collection makefile for: ruby-mpi
-# Date created: 2005 Apr 24
-# Whom: mneumann@ntecs.de
-#
-# $FreeBSD$
-#
-
-PORTNAME= mpi
-PORTVERSION= 0.4
-PORTREVISION= 5
-CATEGORIES= net ruby
-MASTER_SITES= SF/${PORTNAME}ruby/${PORTNAME}ruby/${PORTNAME}ruby-${PORTVERSION}
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}_ruby-${PORTVERSION}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Ruby binding of MPI (Message Passing Interface)
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-BUILD_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
-RUN_DEPENDS= ${LOCALBASE}/lib/libmpich.a:${PORTSDIR}/net/mpich2
-
-USE_BZIP2= yes
-USE_RUBY= yes
-HAS_CONFIGURE= yes
-
-MAN1= mpi_ruby.1
-MAN3= MPI_Comm.3 MPI_Exception.3 MPI_Group.3 MPI_Keyval.3 MPI_Op.3 MPI_Request.3 \
- MPI_Ruby.3 MPI_Status.3
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/mpi_ruby ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/docs/man/man1/*.1 ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/docs/man/man3/*.3 ${PREFIX}/man/man3
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${MKDIR} ${RUBY_MODDOCDIR}
- ${MKDIR} ${RUBY_MODDOCDIR}/html
- ${MKDIR} ${RUBY_MODDOCDIR}/rd
-
- ${CP} ${WRKSRC}/examples/*.rb ${RUBY_MODEXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${WRKSRC}/docs/MPI \
- ${RUBY_MODDOCDIR}/
- ${INSTALL_DATA} ${WRKSRC}/docs/html/*.html ${RUBY_MODDOCDIR}/html/
- ${INSTALL_DATA} ${WRKSRC}/docs/rd/*.rd ${RUBY_MODDOCDIR}/rd/
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/net/ruby-mpi/distinfo b/net/ruby-mpi/distinfo
deleted file mode 100644
index bf7152d64f1f..000000000000
--- a/net/ruby-mpi/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ruby/mpi_ruby-0.4.tar.bz2) = 63342c8ba0915f8ccdddc7eaac4a2c991f97d3cb613a6474c16fc18a2837d953
-SIZE (ruby/mpi_ruby-0.4.tar.bz2) = 102687
diff --git a/net/ruby-mpi/files/patch-configure b/net/ruby-mpi/files/patch-configure
deleted file mode 100644
index 6e993ef6c1f5..000000000000
--- a/net/ruby-mpi/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.orig Mon Jun 30 14:10:21 2003
-+++ configure Tue Jan 17 14:03:02 2006
-@@ -2791,8 +2791,9 @@
- echo "${ECHO_T}$RUBY_CFLAGS" >&6
- echo "$as_me:$LINENO: checking ruby LIBS" >&5
- echo $ECHO_N "checking ruby LIBS... $ECHO_C" >&6
-+ RUBY_LIBS=`ruby -e "require 'rbconfig'" -e "print '-l' + Config::MAKEFILE_CONFIG['RUBY_SO_NAME'] + ' ' + Config::MAKEFILE_CONFIG['LIBS']"`
- RB_LIB_DIR=`$RUBY -e 'require "rbconfig"; puts Config::CONFIG["libdir"]'`
-- RUBY_LIBS="-lruby -L$RB_LIB_DIR"
-+ RUBY_LIBS="$RUBY_LIBS -L$RB_LIB_DIR"
- echo "$as_me:$LINENO: result: $RUBY_LIBS" >&5
- echo "${ECHO_T}$RUBY_LIBS" >&6
- fi
diff --git a/net/ruby-mpi/pkg-descr b/net/ruby-mpi/pkg-descr
deleted file mode 100644
index b56b6da8f39d..000000000000
--- a/net/ruby-mpi/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-MPI Ruby is a Ruby binding of MPI. The primary goal in making this binding was
-to make the power of MPI available to Ruby users in a way that fits into the
-language's object oriented model. In order to do this, the buffer and datatype
-management necessary in the C, C++, and Fortran bindings have been removed.
-What this means is that MPI Ruby allows you to treat objects as messages.
-
-MPI Ruby also aims to be a complete binding to MPI in that it offers access to
-nearly all functionality of MPI. While there is not a one-to-one correspondence
-to functions and constants in the Ruby and C/C++/Fortran bindings, all of the
-communication and topology features are available. There are fewer methods in
-the Ruby binding than there are functions in the C/C++/Fortran bindings, but
-this is mainly due to the fact that the programmer no longer needs to deal with
-buffers and datatypes.
-
-Author: Emil Ong
-WWW: http://mpiruby.sourceforge.net/
diff --git a/net/ruby-mpi/pkg-plist b/net/ruby-mpi/pkg-plist
deleted file mode 100644
index 789c2a47b1e2..000000000000
--- a/net/ruby-mpi/pkg-plist
+++ /dev/null
@@ -1,38 +0,0 @@
-bin/mpi_ruby
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/allgather.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/allreduce.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/basic.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/bcast.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/gather.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/hello.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/irecv.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/op.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/red.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/redhalt.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/redsubmit.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/reduce.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/rpi.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MPI
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi_comm.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi_exception.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi_group.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi_keyval.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi_op.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi_request.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/html/mpi_status.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi_comm.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi_exception.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi_group.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi_keyval.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi_op.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi_request.rd
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rd/mpi_status.rd
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/html
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/rd
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/net/ruby-nis/Makefile b/net/ruby-nis/Makefile
deleted file mode 100644
index a0e7b662ee2e..000000000000
--- a/net/ruby-nis/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# New ports collection makefile for: ruby-nis
-# Date created: 21 June 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= nis
-PORTVERSION= 0.1.1
-PORTREVISION= 1
-CATEGORIES= net ruby
-MASTER_SITES= SF/ruby-${PORTNAME}/ruby-${PORTNAME}/${PORTVERSION}
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= A Ruby library to use the NIS/YP API
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-
-WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
-INSTALL_TARGET= site-install
-
-DOCS_EN= README README.html
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_MODEXAMPLESDIR}/
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/net/ruby-nis/distinfo b/net/ruby-nis/distinfo
deleted file mode 100644
index 2605a6a84a27..000000000000
--- a/net/ruby-nis/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ruby/ruby-nis-0.1.1.tar.gz) = 003bb51a893851939d72f3ac6f2a56f5f08d345cc8b14cca7069a9514fef791a
-SIZE (ruby/ruby-nis-0.1.1.tar.gz) = 4091
diff --git a/net/ruby-nis/files/patch-extconf.rb b/net/ruby-nis/files/patch-extconf.rb
deleted file mode 100644
index 8f15e895e352..000000000000
--- a/net/ruby-nis/files/patch-extconf.rb
+++ /dev/null
@@ -1,13 +0,0 @@
---- extconf.rb.orig Fri Apr 20 14:38:57 2001
-+++ extconf.rb Thu Jun 21 21:24:05 2001
-@@ -6,8 +6,8 @@
- nis_h = have_header('rpcsvc/nis.h')
- ypclnt_h = have_header('rpcsvc/ypclnt.h')
- ypprot_h = have_header('rpcsvc/yp_prot.h')
--libnsl = have_library('nsl')
-+have_library('nsl')
-
--if( libnsl && ypclnt_h && ypprot_h )
-+if( have_func("yp_all") && ypclnt_h && ypprot_h )
- create_makefile('nis')
- end
diff --git a/net/ruby-nis/files/patch-yp.c b/net/ruby-nis/files/patch-yp.c
deleted file mode 100644
index a0cfae6260b5..000000000000
--- a/net/ruby-nis/files/patch-yp.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- yp.c.orig Fri Apr 20 16:07:42 2001
-+++ yp.c Thu Jun 21 21:30:30 2001
-@@ -3,6 +3,7 @@
- */
-
- #include "nis.h"
-+#include <rpc/rpc.h>
- #include <rpcsvc/ypclnt.h>
- #include <rpcsvc/yp_prot.h>
-
diff --git a/net/ruby-nis/pkg-descr b/net/ruby-nis/pkg-descr
deleted file mode 100644
index 04d888bc3b25..000000000000
--- a/net/ruby-nis/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Ruby-nis is a ruby library to use the NIS/YP API.
-
-WWW: http://sourceforge.net/projects/ruby-nis/
-Author: Takaaki Tateishi <ttate@users.sourceforge.net>
diff --git a/net/ruby-nis/pkg-plist b/net/ruby-nis/pkg-plist
deleted file mode 100644
index 325534979f11..000000000000
--- a/net/ruby-nis/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-%%RUBY_SITEARCHLIBDIR%%/nis.so
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/yp_all.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/yp_all2.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/yp_first.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/yp_match.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.html
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/net/ruby-pcap/Makefile b/net/ruby-pcap/Makefile
deleted file mode 100644
index 89bbce17b9a8..000000000000
--- a/net/ruby-pcap/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# New ports collection makefile for: Ruby/Pcap
-# Date created: 20 Nov 2000
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= pcap
-PORTVERSION= 0.6
-PORTREVISION= 2
-CATEGORIES= net ruby
-MASTER_SITES= http://www.goto.info.waseda.ac.jp/~fukusima/ruby/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Ruby interface to LBL Packet Capture library (libpcap)
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-CONFIGURE_ARGS= --with-pcap-dir=/usr
-INSTALL_TARGET= site-install
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${WRKSRC}/doc/* \
- ${RUBY_MODDOCDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README.ja ${WRKSRC}/doc-ja/* \
- ${RUBY_MODDOCDIR}/ja/
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/net/ruby-pcap/distinfo b/net/ruby-pcap/distinfo
deleted file mode 100644
index 4a6d193d92fa..000000000000
--- a/net/ruby-pcap/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ruby/ruby-pcap-0.6.tar.gz) = 377a927efde4c5505a59648c83d3fefc83f8338b64b71e9c0cb874bd06107b46
-SIZE (ruby/ruby-pcap-0.6.tar.gz) = 37539
diff --git a/net/ruby-pcap/files/patch-Pcap.c b/net/ruby-pcap/files/patch-Pcap.c
deleted file mode 100644
index 8460e5d49447..000000000000
--- a/net/ruby-pcap/files/patch-Pcap.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- Pcap.c.orig 2008-05-01 15:26:25.000000000 -0500
-+++ Pcap.c 2008-05-01 15:27:21.000000000 -0500
-@@ -782,9 +782,9 @@
- /* define class PcapStat */
- cPcapStat = rb_funcall(rb_cStruct, rb_intern("new"), 4,
- Qnil,
-- INT2NUM(rb_intern("recv")),
-- INT2NUM(rb_intern("drop")),
-- INT2NUM(rb_intern("ifdrop")));
-+ ID2SYM(rb_intern("recv")),
-+ ID2SYM(rb_intern("drop")),
-+ ID2SYM(rb_intern("ifdrop")));
- rb_define_const(mPcap, "Stat", cPcapStat);
-
- /* define exception classes */
diff --git a/net/ruby-pcap/pkg-descr b/net/ruby-pcap/pkg-descr
deleted file mode 100644
index 0d2d34e0f954..000000000000
--- a/net/ruby-pcap/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-Ruby interface to LBL Packet Capture library (libpcap). This library
-also includes classes to access packet header fields.
-
-It is much easier to code in Ruby/Pcap than to code in C and use
-libpcap directly.
-
-Author: Masaki Fukushima <fukusima@goto.info.waseda.ac.jp>
-WWW: http://www.goto.info.waseda.ac.jp/~fukusima/ruby/pcap-e.html
diff --git a/net/ruby-pcap/pkg-plist b/net/ruby-pcap/pkg-plist
deleted file mode 100644
index 117b2ca6a3ed..000000000000
--- a/net/ruby-pcap/pkg-plist
+++ /dev/null
@@ -1,40 +0,0 @@
-%%RUBY_SITEARCHLIBDIR%%/pcap.so
-%%RUBY_SITELIBDIR%%/pcap_misc.rb
-%%RUBY_SITELIBDIR%%/pcaplet.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Capture.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Dumper.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Filter.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ICMPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/IPAddress.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/IPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Packet.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Pcap.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/PcapError.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/Pcaplet.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/TCPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/TruncatedPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/UDPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Capture.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Dumper.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Filter.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/ICMPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/IPAddress.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/IPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Packet.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Pcap.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/PcapError.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/Pcaplet.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/TCPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/TruncatedPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/UDPPacket.html
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/index.html
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/httpdump.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tcpdump.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/net/ruby-romp/Makefile b/net/ruby-romp/Makefile
deleted file mode 100644
index 5ed0d2e6ab39..000000000000
--- a/net/ruby-romp/Makefile
+++ /dev/null
@@ -1,60 +0,0 @@
-# New ports collection makefile for: ROMP
-# Date created: 24 August 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= romp
-PORTVERSION= 0.2
-CATEGORIES= net ruby
-MASTER_SITES= http://rubystuff.org/romp/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} romp.html
-DIST_SUBDIR= ruby
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= The Ruby Object Message Proxy
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-IGNOREFILES= romp.html
-
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-
-INSTALL_TARGET= site-install
-
-EXAMPLES= client.rb server.rb
-DOCS= romp.html
-
-post-extract:
- ${MKDIR} ${WRKSRC}/lib
-.for f in romp.rb
- ${MV} ${WRKSRC}/${f} ${WRKSRC}/lib/
-.endfor
- ${CP} ${DISTDIR}/${DIST_SUBDIR}/romp.html ${WRKSRC}/
-
-post-patch:
- ${RUBY} -i~ -pe 'sub /^(#include\s*<stdint\.h>)/, "/*\\1*/"' ${WRKSRC}/*.c
- ${RUBY} -i~ -pe 'sub /(.*CFLAGS)/, "#\\1/"' ${WRKSRC}/extconf.rb
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
-.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
-.endfor
- ${MKDIR} ${RUBY_MODDOCDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
-.endfor
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/net/ruby-romp/distinfo b/net/ruby-romp/distinfo
deleted file mode 100644
index 5ccba0075cc5..000000000000
--- a/net/ruby-romp/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-SHA256 (ruby/romp-0.2.tar.gz) = 863edfeae972622fc6c3ba81e360e13e6c69d5dfe6d55a5d4f93c6ca4cabf242
-SIZE (ruby/romp-0.2.tar.gz) = 11762
-SHA256 (ruby/romp.html) = IGNORE
diff --git a/net/ruby-romp/pkg-descr b/net/ruby-romp/pkg-descr
deleted file mode 100644
index a4ce6b140ddc..000000000000
--- a/net/ruby-romp/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-ROMP is the Ruby Object Message Proxy. It is sort of like drb
-(distributed Ruby) in that it allows a Ruby client program to
-transparently talk to an object that is sitting on a server. Its
-features include:
-
-- Up to 40000 messages per second
-
-- Allows more than one object to reside on the server; supports a sort
- for naming service for retrieving references to objects.
-
-- Fully thread-safe, provided the object sitting on the server is
- thread-safe.
-
-- Supports one-way calls, so the client does not have to block waiting
- for a response from the server.
-
-- Allows exceptions to be propagated from server to client; messages
- the backtrace to make debugging easier.
-
-Author: Paul Brannan (paul at atdesk.com)
-WWW: http://rubystuff.org/romp/
diff --git a/net/ruby-romp/pkg-plist b/net/ruby-romp/pkg-plist
deleted file mode 100644
index 9f20965edc84..000000000000
--- a/net/ruby-romp/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-%%RUBY_SITEARCHLIBDIR%%/romp_helper.so
-%%RUBY_SITELIBDIR%%/romp.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/client.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/server.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/romp.html
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
diff --git a/net/ruby-spread/Makefile b/net/ruby-spread/Makefile
deleted file mode 100644
index c150d861ca3c..000000000000
--- a/net/ruby-spread/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: ruby-spread
-# Date created: 2002 July 22
-# Whom: seanc@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= spread
-PORTVERSION= 1.0
-CATEGORIES= net ruby
-MASTER_SITES= http://www.omniti.com/~george/rb_spread/
-PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= rb_${PORTNAME}
-DIST_SUBDIR= ruby
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Ruby interface to the Spread library
-
-DEPRECATED= Doesn't work with Ruby 1.9
-EXPIRATION_DATE= 2011-08-03
-
-LIB_DEPENDS= tspread.1:${PORTSDIR}/net/spread
-
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}-${PORTVERSION}
-
-INSTALL_TARGET= site-install
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/flooder.rb ${RUBY_MODEXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/user.rb ${RUBY_MODEXAMPLESDIR}
- ${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
-.endif
-
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
-.endif
-.include <bsd.port.post.mk>
diff --git a/net/ruby-spread/distinfo b/net/ruby-spread/distinfo
deleted file mode 100644
index c95240623007..000000000000
--- a/net/ruby-spread/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ruby/rb_spread.tar.gz) = 34da0e9ff1f829a8f590031f508287fb07d5ff06660b563c0928909c0f306412
-SIZE (ruby/rb_spread.tar.gz) = 5183
diff --git a/net/ruby-spread/files/patch-extconf.rb b/net/ruby-spread/files/patch-extconf.rb
deleted file mode 100644
index 571c59a32b99..000000000000
--- a/net/ruby-spread/files/patch-extconf.rb
+++ /dev/null
@@ -1,9 +0,0 @@
---- extconf.rb.orig Tue Feb 21 00:34:57 2006
-+++ extconf.rb Tue Feb 21 00:35:07 2006
-@@ -1,5 +1,5 @@
- require "mkmf"
- #$LDFLAGS = "-lsp"
--$LOCAL_LIBS = "-ltsp -lpthread"
-+$LOCAL_LIBS = "-ltspread -lpthread"
- create_makefile("spread")
-
diff --git a/net/ruby-spread/pkg-descr b/net/ruby-spread/pkg-descr
deleted file mode 100644
index a716451fef9c..000000000000
--- a/net/ruby-spread/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Ruby Spread is a library interface for the Ruby.
-
-WWW: http://www.spread.org/
diff --git a/net/ruby-spread/pkg-plist b/net/ruby-spread/pkg-plist
deleted file mode 100644
index dbc0bf51eec9..000000000000
--- a/net/ruby-spread/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-%%RUBY_SITEARCHLIBDIR%%/spread.so
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/flooder.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/user.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
-%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%