aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/libsocketcpp/Makefile7
-rw-r--r--net/libsocketcpp/files/patch-src::tcpservertest.cpp17
-rw-r--r--net/libsocketcpp/files/patch-src::tcptest.cpp20
3 files changed, 33 insertions, 11 deletions
diff --git a/net/libsocketcpp/Makefile b/net/libsocketcpp/Makefile
index 32dd85aaccca..5fb14dc09245 100644
--- a/net/libsocketcpp/Makefile
+++ b/net/libsocketcpp/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: libsocketcpp
-# Date created: Aug 12, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= libsocketcpp
PORTVERSION= 1.0.7
diff --git a/net/libsocketcpp/files/patch-src::tcpservertest.cpp b/net/libsocketcpp/files/patch-src::tcpservertest.cpp
new file mode 100644
index 000000000000..16f672f4dd4a
--- /dev/null
+++ b/net/libsocketcpp/files/patch-src::tcpservertest.cpp
@@ -0,0 +1,17 @@
+--- src/tcpservertest.cpp.orig 2012-12-03 14:28:35.000000000 +0100
++++ src/tcpservertest.cpp 2012-12-03 14:28:46.000000000 +0100
+@@ -30,6 +30,7 @@
+
+ #include "tcpsocket.h"
+
++int
+ main() {
+ printf("\r\nInit Object...");
+ TCPSocket *MyServerSocket = new TCPSocket;
+@@ -67,5 +68,6 @@
+ while(waitpid(-1, NULL, WNOHANG) > 0);
+ }
+
++ return 0;
+ }
+
diff --git a/net/libsocketcpp/files/patch-src::tcptest.cpp b/net/libsocketcpp/files/patch-src::tcptest.cpp
index 02b651505cb5..6dfa402deb74 100644
--- a/net/libsocketcpp/files/patch-src::tcptest.cpp
+++ b/net/libsocketcpp/files/patch-src::tcptest.cpp
@@ -1,12 +1,22 @@
-$FreeBSD$
-
---- src/tcptest.cpp.orig Sun Jun 9 16:03:19 2002
-+++ src/tcptest.cpp Sun Jun 9 16:03:31 2002
-@@ -22,6 +22,7 @@
+--- src/tcptest.cpp.orig 2001-02-16 19:45:31.000000000 +0100
++++ src/tcptest.cpp 2012-12-03 14:27:37.000000000 +0100
+@@ -22,8 +22,10 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#include <sys/types.h>
#include "tcpsocket.h"
++int
main() {
+ char *Host = new char[100];
+ char *Buffer = new char[2048];
+@@ -62,6 +64,8 @@
+ delete [] Buffer;
+ delete [] Host;
+ delete [] TempMsg;
++
++ return 0;
+ }
+
+