aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/imapproxy/Makefile1
-rw-r--r--net/imapproxy/files/patch-ae11
-rw-r--r--net/imapproxy/files/patch-af20
3 files changed, 32 insertions, 0 deletions
diff --git a/net/imapproxy/Makefile b/net/imapproxy/Makefile
index c55cbe6898c1..7ac8ea6487b1 100644
--- a/net/imapproxy/Makefile
+++ b/net/imapproxy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= imapproxy
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.freebsdcluster.org/~lasse/software/ \
${MASTER_SITE_LOCAL}
diff --git a/net/imapproxy/files/patch-ae b/net/imapproxy/files/patch-ae
new file mode 100644
index 000000000000..26af092275f9
--- /dev/null
+++ b/net/imapproxy/files/patch-ae
@@ -0,0 +1,11 @@
+--- network.c.orig Fri Aug 1 06:34:08 2003
++++ network.c Fri Aug 1 06:33:23 2003
+@@ -48,7 +48,7 @@
+ va_start(v, fmt);
+ i = vsnprintf(buf, sizeof(buf), fmt, v);
+ write(s, buf, i);
+- va_end(fmt);
++ va_end(v);
+ }
+
+ /* resolve a hostname to an IP in long notation
diff --git a/net/imapproxy/files/patch-af b/net/imapproxy/files/patch-af
new file mode 100644
index 000000000000..793a64e263f8
--- /dev/null
+++ b/net/imapproxy/files/patch-af
@@ -0,0 +1,20 @@
+--- output.c.orig Fri Aug 1 06:34:16 2003
++++ output.c Fri Aug 1 06:33:29 2003
+@@ -40,7 +40,7 @@
+ vsnprintf(buf, sizeof(buf), fmt, v);
+ //fprintf(stderr,"[DEBUG %d] %s",getpid(),buf);
+ log(LOG_DEBUG,"[DEBUG %d] %s",getpid(),buf);
+- va_end(fmt);
++ va_end(v);
+ }
+ }
+
+@@ -57,7 +57,7 @@
+ openlog(PROGNAME, LOG_PID , config_log_facility);
+ syslog(config_log_facility | level, "%s", buf);
+ //closelog();
+- va_end(fmt);
++ va_end(v);
+ }
+ }
+