aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-ICQ2000/Makefile21
-rw-r--r--net/p5-Net-ICQ2000/distinfo1
-rw-r--r--net/p5-Net-ICQ2000/pkg-comment1
-rw-r--r--net/p5-Net-ICQ2000/pkg-descr2
-rw-r--r--net/p5-Net-ICQ2000/pkg-plist5
6 files changed, 31 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 689f42cf8c51..4f950106976d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -286,6 +286,7 @@
SUBDIR += p5-Net-DLookup
SUBDIR += p5-Net-DNS
SUBDIR += p5-Net-Daemon
+ SUBDIR += p5-Net-ICQ2000
SUBDIR += p5-Net-IPv4Addr
SUBDIR += p5-Net-IPv6Addr
SUBDIR += p5-Net-Jabber
diff --git a/net/p5-Net-ICQ2000/Makefile b/net/p5-Net-ICQ2000/Makefile
new file mode 100644
index 000000000000..e59fa9a069b2
--- /dev/null
+++ b/net/p5-Net-ICQ2000/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: Net-ICQ2000
+# Date created: 06 December 2001
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-ICQ2000
+PORTVERSION= 0.2.1
+CATEGORIES= net perl5
+MASTER_SITES= http://gonzo.kiev.ua/projects/vicq/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kevlo@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::ICQ2000.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-ICQ2000/distinfo b/net/p5-Net-ICQ2000/distinfo
new file mode 100644
index 000000000000..91d15bd215a1
--- /dev/null
+++ b/net/p5-Net-ICQ2000/distinfo
@@ -0,0 +1 @@
+MD5 (Net-ICQ2000-0.2.1.tar.gz) = 8de3b754c408942eab165ab34011db49
diff --git a/net/p5-Net-ICQ2000/pkg-comment b/net/p5-Net-ICQ2000/pkg-comment
new file mode 100644
index 000000000000..2d8015733c9c
--- /dev/null
+++ b/net/p5-Net-ICQ2000/pkg-comment
@@ -0,0 +1 @@
+A perl5 module for ICQv7 protocol realisation
diff --git a/net/p5-Net-ICQ2000/pkg-descr b/net/p5-Net-ICQ2000/pkg-descr
new file mode 100644
index 000000000000..ea1a198b86b6
--- /dev/null
+++ b/net/p5-Net-ICQ2000/pkg-descr
@@ -0,0 +1,2 @@
+Net::ICQ2000 module is designed to give perl scripts access to the
+ICQ network and the functions provided by it, like SMS.
diff --git a/net/p5-Net-ICQ2000/pkg-plist b/net/p5-Net-ICQ2000/pkg-plist
new file mode 100644
index 000000000000..ee89d17f1a35
--- /dev/null
+++ b/net/p5-Net-ICQ2000/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/ICQ2000.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/ICQ2000/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/ICQ2000
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2> /dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2> /dev/null || true