aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/icpld/Makefile17
-rw-r--r--net/ipsumdump/Makefile20
-rw-r--r--net/pear-SOAP/Makefile23
3 files changed, 24 insertions, 36 deletions
diff --git a/net/icpld/Makefile b/net/icpld/Makefile
index 1cd7eafe760a..cf8bbd49219f 100644
--- a/net/icpld/Makefile
+++ b/net/icpld/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: icpld
-# Date created: 04.01.2004
-# Whom: krion@FreeBSD.org
-#
+# Created by: krion@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= icpld
PORTVERSION= 1.1.5
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.ibiblio.org/icpld/download/ \
http://freebsd.unixfreunde.de/sources/
@@ -23,11 +20,11 @@ MAN1= ${PORTNAME}.1
PORTDOCS= README
PLIST_FILES= bin/icpld etc/icpld.conf.sample etc/rc.d/icpld.sh.sample
-OPTIONS= IPV6 "IPv6 internet support" off \
+OPTIONS_DEFINE= IPV6 DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
@@ -42,11 +39,11 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/icpld.sh.sample ${PREFIX}/etc/rc.d
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in README
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ipsumdump/Makefile b/net/ipsumdump/Makefile
index 59e97006643f..91567d322722 100644
--- a/net/ipsumdump/Makefile
+++ b/net/ipsumdump/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: ipsumdump
-# Date created: 12.01.2004
-# Whom: krion@FreeBSD.org
-#
+# Created by: krion@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= ipsumdump
PORTVERSION= 1.82
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.cs.ucla.edu/~kohler/ipsumdump/
@@ -22,10 +19,11 @@ MAN1= ${PORTNAME}.1 ipaggcreate.1 ipaggmanip.1
PORTDOCS= README
PLIST_FILES= bin/ipaggcreate bin/ipsumdump bin/ipaggmanip
-OPTIONS= IPV6 "IPv6 internet support" off \
+OPTIONS_DEFINE= IPV6 DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MIPV6}
.if defined(WITH_IPV6)
CONFIGURE_ARGS+=--enable-ipv6
PLIST_SUB+= IPV6=""
@@ -35,15 +33,11 @@ PLIST_SUB+= IPV6="@comment "
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for i in README
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.if ${OSVERSION} < 700000
-IGNORE= not supported
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index c36ca11e681e..fa99987fb872 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-SOAP
-# Date created: 05 April 2004
-# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
-#
+# Created by: Thierry Thomas (<thierry@FreeBSD.org>)
# $FreeBSD$
-#
PORTNAME= SOAP
PORTVERSION= 0.13.0
@@ -18,25 +14,26 @@ RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
LATEST_LINK= pear-SOAP
-OPTIONS= PEAR_MAIL "PEAR::Mail support" off \
- PEAR_MAIL_MIME "PEAR::Mail::Mime support" off \
- PEAR_NET_DIME "PEAR::Net::DIME support" off
+OPTIONS_DEFINE= PEAR_MAIL PEAR_MAIL_MIME PEAR_NET_DIME
+PEAR_MAIL_DESC= PEAR::Mail support
+PEAR_MAIL_MIME_DESC= PEAR::Mail::Mime support
+PEAR_NET_DIME_DESC= PEAR::Net::DIME support
PEAR_AUTOINSTALL=yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PEAR_MAIL)
+.if ${PORT_OPTIONS:MPEAR_MAIL}
BUILD_DEPENDS+= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail
.endif
-.if defined(WITH_PEAR_MAIL_MIME)
+.if ${PORT_OPTIONS:MPEAR_MAIL_MIME}
BUILD_DEPENDS+= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
.endif
-.if defined(WITH_PEAR_NET_DIME)
+.if ${PORT_OPTIONS:MPEAR_NET_DIME}
BUILD_DEPENDS+= ${PEARDIR}/Net/DIME.php:${PORTSDIR}/net/pear-Net_DIME
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>