aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/dbeacon/Makefile27
-rw-r--r--net/dbeacon/distinfo3
-rw-r--r--net/dbeacon/files/dbeacon.in28
-rw-r--r--net/dbeacon/pkg-descr7
5 files changed, 66 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 24a22146dd59..1c98330b6135 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -107,6 +107,7 @@
SUBDIR += danamics
SUBDIR += dante
SUBDIR += datapipe
+ SUBDIR += dbeacon
SUBDIR += delegate
SUBDIR += desktop-data-model
SUBDIR += despoof
diff --git a/net/dbeacon/Makefile b/net/dbeacon/Makefile
new file mode 100644
index 000000000000..dfd510845a2f
--- /dev/null
+++ b/net/dbeacon/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: dbeacon
+# Date created: July 19, 2009
+# Whom: Antonio Querubin <tony@lava.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbeacon
+PORTVERSION= 0.3.9.1
+CATEGORIES= net
+MASTER_SITES= http://fivebits.net/files/dbeacon/
+
+MAINTAINER= tony@lava.net
+COMMENT= Distributed multicast beacon server
+
+PLIST_FILES= bin/dbeacon
+
+USE_GMAKE= yes
+MAN1= dbeacon.1
+
+USE_RC_SUBR= dbeacon
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/docs/dbeacon.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/dbeacon/distinfo b/net/dbeacon/distinfo
new file mode 100644
index 000000000000..7d743653b3e7
--- /dev/null
+++ b/net/dbeacon/distinfo
@@ -0,0 +1,3 @@
+MD5 (dbeacon-0.3.9.1.tar.gz) = abb202b01f9a17c1fb96d4c247d9e825
+SHA256 (dbeacon-0.3.9.1.tar.gz) = 0fbaa178a07802b66bd5497ca9a9c57f0db3fb9b5795c46c051263c13bae2d06
+SIZE (dbeacon-0.3.9.1.tar.gz) = 43893
diff --git a/net/dbeacon/files/dbeacon.in b/net/dbeacon/files/dbeacon.in
new file mode 100644
index 000000000000..6f29bab71711
--- /dev/null
+++ b/net/dbeacon/files/dbeacon.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: dbeacon
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable dbeacon.
+#
+# dbeacon_enable="YES"
+# dbeacon_flags="" Extra flags passed to start command.
+#
+# See dbeacon(1) for flags.
+
+dbeacon_enable=${dbeacon_enable-"NO"}
+dbeacon_flags=${dbeacon_flags-""}
+
+. %%RC_SUBR%%
+
+name="dbeacon"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/${name}"
+
+load_rc_config $name
+
+run_rc_command "$1"
diff --git a/net/dbeacon/pkg-descr b/net/dbeacon/pkg-descr
new file mode 100644
index 000000000000..b1ba58ab1895
--- /dev/null
+++ b/net/dbeacon/pkg-descr
@@ -0,0 +1,7 @@
+Dbeacon is a distributed multicast monitoring tool. The main purpose of a
+beacon is to monitor other beacons' reachability and to collect statistics
+such as loss, delay, and jitter between beacons. Dbeacon supports both
+IPv4 and IPv6 multicast and supports collecting information using both Any
+Source Multicast (ASM) and Source-Specific Multicast (SSM).
+
+WWW: http://fivebits.net/proj/dbeacon