aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ntalk/Makefile29
-rw-r--r--net/ntalk/distinfo1
-rw-r--r--net/ntalk/files/patch-ntalk.c11
-rw-r--r--net/ntalk/pkg-comment1
-rw-r--r--net/ntalk/pkg-descr8
-rw-r--r--net/ntalk/pkg-plist6
7 files changed, 57 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e4a4c6bfb02f..65866a1b34dd 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -229,6 +229,7 @@
SUBDIR += nslint
SUBDIR += nsping
SUBDIR += nstreams
+ SUBDIR += ntalk
SUBDIR += ntimelord
SUBDIR += ntop
SUBDIR += ntp
diff --git a/net/ntalk/Makefile b/net/ntalk/Makefile
new file mode 100644
index 000000000000..80e63f6b8764
--- /dev/null
+++ b/net/ntalk/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: ntalk
+# Date created: 26 August 2001
+# Whom: Gea-Suan Lin (gslin@ccca.nctu.edu.tw)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ntalk
+PORTVERSION= 0.3.1
+CATEGORIES= net
+MASTER_SITES= http://kab.w.interia.pl/
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in COPYING ChangeLog INSTALL README
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ntalk/distinfo b/net/ntalk/distinfo
new file mode 100644
index 000000000000..62bbb85b04a8
--- /dev/null
+++ b/net/ntalk/distinfo
@@ -0,0 +1 @@
+MD5 (ntalk-0.3.1.tar.gz) = 52c599ad8e1ff7b71e186cf39cc5b3cb
diff --git a/net/ntalk/files/patch-ntalk.c b/net/ntalk/files/patch-ntalk.c
new file mode 100644
index 000000000000..019cb016e7cd
--- /dev/null
+++ b/net/ntalk/files/patch-ntalk.c
@@ -0,0 +1,11 @@
+--- ntalk.c.orig Sun Aug 26 08:02:08 2001
++++ ntalk.c Sun Aug 26 08:02:22 2001
+@@ -16,7 +16,7 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <unistd.h>
+-#include <ncurses/ncurses.h>
++#include <curses.h>
+
+ #define MESSAGE 0
+ #define NICK 1
diff --git a/net/ntalk/pkg-comment b/net/ntalk/pkg-comment
new file mode 100644
index 000000000000..27722bf840e5
--- /dev/null
+++ b/net/ntalk/pkg-comment
@@ -0,0 +1 @@
+A console chat application written with ncurse
diff --git a/net/ntalk/pkg-descr b/net/ntalk/pkg-descr
new file mode 100644
index 000000000000..0b2a6951fd82
--- /dev/null
+++ b/net/ntalk/pkg-descr
@@ -0,0 +1,8 @@
+ntalk is a chat console app written with ncurses. It's designed to work in
+all kinds of networks (LAN/WAN) and to be much more friendly and functional
+than Unix talk.
+
+WWW: http://kab.w.interia.pl/
+
+- Gea-Suan Lin
+ gslin@ccca.nctu.edu.tw
diff --git a/net/ntalk/pkg-plist b/net/ntalk/pkg-plist
new file mode 100644
index 000000000000..a267444e17c1
--- /dev/null
+++ b/net/ntalk/pkg-plist
@@ -0,0 +1,6 @@
+bin/ntalk
+%%PORTDOCS%%share/doc/ntalk/COPYING
+%%PORTDOCS%%share/doc/ntalk/ChangeLog
+%%PORTDOCS%%share/doc/ntalk/INSTALL
+%%PORTDOCS%%share/doc/ntalk/README
+%%PORTDOCS%%@dirrm share/doc/ntalk