aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/echoping/Makefile30
-rw-r--r--net/echoping/pkg-plist20
2 files changed, 20 insertions, 30 deletions
diff --git a/net/echoping/Makefile b/net/echoping/Makefile
index 8df5e9269eaa..7b3f6401aa33 100644
--- a/net/echoping/Makefile
+++ b/net/echoping/Makefile
@@ -3,7 +3,7 @@
PORTNAME= echoping
PORTVERSION= 6.0.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net ipv6
MASTER_SITES= SF
@@ -23,29 +23,19 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-http --enable-icp --enable-smtp --with-ssl \
--enable-ttcp --enable-tos --with-libidn=${LOCALBASE} \
--enable-plugin="${PING_PLUGINS}"
+INSTALL_TARGET= install-strip
PING_PLUGINS= dns random whois
OPTIONS_DEFINE= LDAP PGSQL
-OPTIONS_DEFAULT= LDAP
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= yes
-PING_PLUGINS+= ldap
-PLIST_SUB= WITH_LDAP=""
-.else
-PLIST_SUB= WITH_LDAP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-PING_PLUGINS+= postgresql
-PLIST_SUB+= WITH_PGSQL=""
-.else
-PLIST_SUB+= WITH_PGSQL="@comment "
-.endif
+OPTIONS_DEFAULT=LDAP
+OPTIONS_SUB= yes
+
+LDAP_USE= OPENLDAP=yes
+LDAP_VARS= PING_PLUGINS+=ldap
+
+PGSQL_USES= pgsql
+PGSQL_VARS= PING_PLUGINS+=postgresql
post-patch:
@${REINPLACE_CMD} '/^echoping_LDADD =/s/$$/ -lm/' ${WRKSRC}/Makefile.in
diff --git a/net/echoping/pkg-plist b/net/echoping/pkg-plist
index ac44660bb397..c174c1d30464 100644
--- a/net/echoping/pkg-plist
+++ b/net/echoping/pkg-plist
@@ -5,14 +5,14 @@ lib/echoping/dns.a
lib/echoping/dns.so
lib/echoping/dns.so.0
lib/echoping/dns.so.0.0.0
-%%WITH_LDAP%%lib/echoping/ldap.a
-%%WITH_LDAP%%lib/echoping/ldap.so
-%%WITH_LDAP%%lib/echoping/ldap.so.0
-%%WITH_LDAP%%lib/echoping/ldap.so.0.0.0
-%%WITH_PGSQL%%lib/echoping/postgresql.a
-%%WITH_PGSQL%%lib/echoping/postgresql.so
-%%WITH_PGSQL%%lib/echoping/postgresql.so.0
-%%WITH_PGSQL%%lib/echoping/postgresql.so.0.0.0
+%%LDAP%%lib/echoping/ldap.a
+%%LDAP%%lib/echoping/ldap.so
+%%LDAP%%lib/echoping/ldap.so.0
+%%LDAP%%lib/echoping/ldap.so.0.0.0
+%%PGSQL%%lib/echoping/postgresql.a
+%%PGSQL%%lib/echoping/postgresql.so
+%%PGSQL%%lib/echoping/postgresql.so.0
+%%PGSQL%%lib/echoping/postgresql.so.0.0.0
lib/echoping/random.a
lib/echoping/random.so
lib/echoping/random.so.0
@@ -23,7 +23,7 @@ lib/echoping/whois.so.0
lib/echoping/whois.so.0.0.0
man/man1/echoping.1.gz
man/man1/echoping_dns.1.gz
-%%WITH_LDAP%%man/man1/echoping_ldap.1.gz
-%%WITH_PGSQL%%man/man1/echoping_postgresql.1.gz
+%%LDAP%%man/man1/echoping_ldap.1.gz
+%%PGSQL%%man/man1/echoping_postgresql.1.gz
man/man1/echoping_random.1.gz
man/man1/echoping_whois.1.gz