aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/mosh/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/mosh/Makefile b/net/mosh/Makefile
index 4a200343af75..bd3d1a8e4011 100644
--- a/net/mosh/Makefile
+++ b/net/mosh/Makefile
@@ -12,7 +12,7 @@ COMMENT= Mobile terminal that supports intermittent connectivity
LICENSE= GPLv3
-LIB_DEPENDS= protobuf:${PORTSDIR}/devel/protobuf
+LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
USE_PERL5= run
GNU_CONFIGURE= yes
@@ -26,14 +26,13 @@ LATEST_LINK= mosh-term
CONFLICTS_INSTALL= mosh-0.[2-9].*
-PLIST_FILES= bin/mosh bin/mosh-server bin/mosh-client
-MAN1= mosh-client.1 mosh-server.1 mosh.1
+PLIST_FILES= bin/mosh bin/mosh-server bin/mosh-client \
+ man/man1/mosh-client.1.gz man/man1/mosh-server.1.gz man/man1/mosh.1.gz
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 900004
-LIB_DEPENDS+= utempter:${PORTSDIR}/sysutils/libutempter
+LIB_DEPENDS+= libutempter.so:${PORTSDIR}/sysutils/libutempter
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.endif