aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/ssvnc/Makefile4
-rw-r--r--net/tightvnc/Makefile3
2 files changed, 4 insertions, 3 deletions
diff --git a/net/ssvnc/Makefile b/net/ssvnc/Makefile
index 1f630dce97ea..d04dfc303a48 100644
--- a/net/ssvnc/Makefile
+++ b/net/ssvnc/Makefile
@@ -13,7 +13,6 @@ COMMENT= Enhanced TightVNC Viewer (SSVNC: SSL/SSH VNC viewer)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= stunnel:${PORTSDIR}/security/stunnel \
xterm:${PORTSDIR}/x11/xterm
@@ -21,6 +20,7 @@ RUN_DEPENDS= stunnel:${PORTSDIR}/security/stunnel \
OPTIONS_DEFINE= ULTRAFTP DOCS
ULTRAFTP_DESC= UltraVNC File Transfer support (Java required)
+USES= imake:env
USE_XORG= xi xmu xt xaw ice xpm xext sm
USE_TK_WRAPPER= yes
USE_PERL5_RUN= yes
@@ -55,7 +55,7 @@ post-patch:
.endif
do-configure:
- @cd ${WRKSRC} && ${GMAKE} config
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} config
post-install:
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 69cf3d362939..4e06e1311140 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -22,10 +22,11 @@ CONFLICTS= tridiavnc-[0-9]* vnc-[0-9]*
WRKSRC= ${WRKDIR}/vnc_unixsrc
+USES= imake
+CFLAGS+= -Wno-return-type
USE_GCC= yes
USE_BZIP2= yes
USE_PERL5= yes
-USE_IMAKE= yes
USE_XORG= xaw
ALL_TARGET= World
NO_INSTALL_MANPAGES= yes