aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/linux-c6-openldap/Makefile34
-rw-r--r--net/linux-c6-openldap/distinfo.i6864
-rw-r--r--net/linux-c6-tcp_wrappers-libs/Makefile22
-rw-r--r--net/linux-c6-tcp_wrappers-libs/distinfo.i6864
-rw-r--r--net/linux-c6-tcp_wrappers-libs/pkg-descr3
-rw-r--r--net/linux-c6-tcp_wrappers-libs/pkg-plist14
-rw-r--r--net/linux-f10-nss_ldap/Makefile6
-rw-r--r--net/linux-f10-openldap/Makefile7
9 files changed, 89 insertions, 7 deletions
diff --git a/net/Makefile b/net/Makefile
index 4e0ef61a51eb..38ee5ca45ce9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -328,6 +328,8 @@
SUBDIR += linc-reference
SUBDIR += linknx
SUBDIR += linphone
+ SUBDIR += linux-c6-openldap
+ SUBDIR += linux-c6-tcp_wrappers-libs
SUBDIR += linux-f10-nss_ldap
SUBDIR += linux-f10-openldap
SUBDIR += linuxigd
diff --git a/net/linux-c6-openldap/Makefile b/net/linux-c6-openldap/Makefile
new file mode 100644
index 000000000000..7ff9910f94dd
--- /dev/null
+++ b/net/linux-c6-openldap/Makefile
@@ -0,0 +1,34 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= openldap
+PORTVERSION= 2.4.23
+CATEGORIES= net linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Lightweight Directory Access Protocol libraries (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-f10-openldap-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+#USE_LINUX_APPS= openssl
+RPMVERSION= 32.el6_4.1
+USE_LINUX_RPM= yes
+USE_LDCONFIG= yes
+DESCR= ${.CURDIR}/../openldap24-server/pkg-descr
+
+PLIST_FILES= lib/liblber-2.4.so.2 lib/liblber-2.4.so.2.5.6 lib/libldap-2.4.so.2 lib/libldap-2.4.so.2.5.6 lib/libldap_r-2.4.so.2 lib/libldap_r-2.4.so.2.5.6 lib/libldif-2.4.so.2 lib/libldif-2.4.so.2.5.6 etc/openldap usr/share/man/man5/ldap.conf.5.gz usr/share/man/man5/ldif.5.gz
+DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= ANNOUNCEMENT CHANGES COPYRIGHT LICENSE README
+
+# do not install any openldap configuration directories/files
+post-extract:
+ ${RM} -rf ${WRKSRC}/etc
+
+# use a native openldap configuration directories/files
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc
+ ${LN} -sf ${LOCALBASE}/etc/openldap ${STAGEDIR}${PREFIX}/etc/openldap
+
+.include <bsd.port.mk>
diff --git a/net/linux-c6-openldap/distinfo.i686 b/net/linux-c6-openldap/distinfo.i686
new file mode 100644
index 000000000000..3d9242f17eea
--- /dev/null
+++ b/net/linux-c6-openldap/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/openldap-2.4.23-32.el6_4.1.i686.rpm) = 59051fb70166b64d80f9dd7d5d0d617c14993183b36d08c141810ad6cccfb9e5
+SIZE (rpm/i686/centos/6.5/openldap-2.4.23-32.el6_4.1.i686.rpm) = 273192
+SHA256 (rpm/i686/centos/6.5/openldap-2.4.23-32.el6_4.1.src.rpm) = 9e163eeb01cbd47353daf36f9735c3418fe1b7568e153f1ddf1fc2bdc7ac5738
+SIZE (rpm/i686/centos/6.5/openldap-2.4.23-32.el6_4.1.src.rpm) = 5309761
diff --git a/net/linux-c6-tcp_wrappers-libs/Makefile b/net/linux-c6-tcp_wrappers-libs/Makefile
new file mode 100644
index 000000000000..5787bbe6cac6
--- /dev/null
+++ b/net/linux-c6-tcp_wrappers-libs/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= tcp_wrappers-libs
+PORTVERSION= 7.6
+CATEGORIES= net linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Libraries tcp wrappers (Linux CentOS ${LINUX_DIST_VER})
+
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= xorglibs
+
+RPMVERSION= 57.el6
+USE_LDCONFIG= yes
+
+DOCSDIR= ${PREFIX}/usr/share/doc/tcp_wrappers-${PORTVERSION}
+
+SRC_DISTFILES= tcp_wrappers-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}
+
+.include <bsd.port.mk>
diff --git a/net/linux-c6-tcp_wrappers-libs/distinfo.i686 b/net/linux-c6-tcp_wrappers-libs/distinfo.i686
new file mode 100644
index 000000000000..8e0b34e3e9d1
--- /dev/null
+++ b/net/linux-c6-tcp_wrappers-libs/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/tcp_wrappers-libs-7.6-57.el6.i686.rpm) = 0af672d37c071d898a6207b36f98afa70544531d958138a7a98f897703b0bd00
+SIZE (rpm/i686/centos/6.5/tcp_wrappers-libs-7.6-57.el6.i686.rpm) = 63364
+SHA256 (rpm/i686/centos/6.5/tcp_wrappers-7.6-57.el6.src.rpm) = b5dc9f2893acf4fbbe7e727273793d21cfdd932c66ddb18ef4d0394f13b12988
+SIZE (rpm/i686/centos/6.5/tcp_wrappers-7.6-57.el6.src.rpm) = 140453
diff --git a/net/linux-c6-tcp_wrappers-libs/pkg-descr b/net/linux-c6-tcp_wrappers-libs/pkg-descr
new file mode 100644
index 000000000000..eac66853ae62
--- /dev/null
+++ b/net/linux-c6-tcp_wrappers-libs/pkg-descr
@@ -0,0 +1,3 @@
+tcp wrappers library
+
+WWW: http://www.centos.org
diff --git a/net/linux-c6-tcp_wrappers-libs/pkg-plist b/net/linux-c6-tcp_wrappers-libs/pkg-plist
new file mode 100644
index 000000000000..cfed659aa554
--- /dev/null
+++ b/net/linux-c6-tcp_wrappers-libs/pkg-plist
@@ -0,0 +1,14 @@
+lib/libwrap.so.0
+lib/libwrap.so.0.7.6
+usr/share/doc/tcp_wrappers-libs-7.6/BLURB
+usr/share/doc/tcp_wrappers-libs-7.6/Banners.Makefile
+usr/share/doc/tcp_wrappers-libs-7.6/CHANGES
+usr/share/doc/tcp_wrappers-libs-7.6/DISCLAIMER
+usr/share/doc/tcp_wrappers-libs-7.6/README
+usr/share/doc/tcp_wrappers-libs-7.6/README.IRIX
+usr/share/doc/tcp_wrappers-libs-7.6/README.NIS
+usr/share/man/man5/hosts.allow.5.gz
+usr/share/man/man5/hosts.deny.5.gz
+usr/share/man/man5/hosts_access.5.gz
+usr/share/man/man5/hosts_options.5.gz
+@dirrmtry usr/share/doc/tcp_wrappers-libs-7.6
diff --git a/net/linux-f10-nss_ldap/Makefile b/net/linux-f10-nss_ldap/Makefile
index 2340fec41a16..156503d5dd3b 100644
--- a/net/linux-f10-nss_ldap/Makefile
+++ b/net/linux-f10-nss_ldap/Makefile
@@ -3,12 +3,11 @@
PORTNAME= nss_ldap
PORTVERSION= ${NSS_LDAP_VERSION}
+PORTREVISION= 1
CATEGORIES= net linux
MASTER_SITES= ftp://ftp.pbone.net/mirror/archive.fedoraproject.org/fedora/linux/updates/testing/10/i386/ \
http://archives.fedoraproject.org/pub/archive/fedora/linux/updates/testing/10/i386/ \
http://herveybayaustralia.com.au/ports/distfiles/
-PKGNAMEPREFIX= linux-f10-
-DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
COMMENT= RFC 2307 NSS Module (Linux Fedora 10)
@@ -20,9 +19,10 @@ OPTIONS_DEFINE= DOCS PAM
NSS_LDAP_VERSION=264
+USE_LINUX= f10
USE_LINUX_RPM= yes
USE_LINUX_PREFIX=yes
-LINUX_DIST_VER= 10
+
RPMVERSION= 6.fc10
USE_LDCONFIG= yes
diff --git a/net/linux-f10-openldap/Makefile b/net/linux-f10-openldap/Makefile
index 714a7e25d82e..fda5cf220bba 100644
--- a/net/linux-f10-openldap/Makefile
+++ b/net/linux-f10-openldap/Makefile
@@ -3,17 +3,16 @@
PORTNAME= openldap
PORTVERSION= 2.4.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net linux
MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
-PKGNAMEPREFIX= linux-f10-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Lightweight Directory Access Protocol libraries (Linux Fedora 10)
+USE_LINUX= f10
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 10
+
RPMVERSION= 1.fc10
USE_LDCONFIG= yes
DESCR= ${.CURDIR}/../openldap24-server/pkg-descr