aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/turnserver/Makefile19
-rw-r--r--net/turnserver/distinfo4
-rw-r--r--net/turnserver/pkg-plist35
3 files changed, 34 insertions, 24 deletions
diff --git a/net/turnserver/Makefile b/net/turnserver/Makefile
index 90a31dd6ce42..37be19d7bf10 100644
--- a/net/turnserver/Makefile
+++ b/net/turnserver/Makefile
@@ -1,15 +1,15 @@
# $FreeBSD$
PORTNAME= turnserver
-PORTVERSION= 3.2.2.5
-PORTREVISION= 2
+PORTVERSION= 3.2.4.4
CATEGORIES= net
-MASTER_SITES= http://turnserver.open-sys.org/downloads/v${PORTVERSION}/ \
- http://turnserver.open-sys.org/downloads/extradocs/ \
- http://www.olegmoskalenko.com/turnserver/v${PORTVERSION}/ \
- http://www.olegmoskalenko.com/turnserver/extradocs/
+MASTER_SITES= http://turnserver.open-sys.org/downloads/v${PORTVERSION}/:prog \
+ http://turnserver.open-sys.org/downloads/extradocs/:xdocs \
+ http://coturn.net/turnserver/v${PORTVERSION}/:prog \
+ http://coturn.net/turnserver/extradocs/:xdocs
PKGNAMEPREFIX=
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} turn.extra.docs-2.0.0.1.tar.gz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:prog \
+ turn.extra.docs-2.0.0.1.tar.gz:xdocs
MAINTAINER= mom040267@gmail.com
COMMENT= STUN/TURN Server; IPv6, DTLS support; RFCs 5389, 5766, 6062, 6156
@@ -22,6 +22,8 @@ CONFLICTS= libevent-1.*
SUB_FILES= pkg-message
+MANPAGES= turnserver.1 turnadmin.1 turnutils.1 turnutils_peer.1 turnutils_stunclient.1 turnutils_uclient.1 rfc5766-turn-server.1
+
USE_OPENSSL= YES
USE_RC_SUBR= turnserver
@@ -62,6 +64,7 @@ longtermsecure/secure_tls_client_c2c_tcp_relay.sh longtermsecure/secure_tls_clie
longtermsecure/secure_udp_c2c.sh longtermsecure/secure_udp_client.sh \
longtermsecure/secure_dos_attack.sh longtermsecure/secure_udp_client.sh \
longtermsecuredb/secure_relay_with_db_psql.sh longtermsecuredb/secure_relay_with_db_mysql.sh \
+longtermsecuredb/secure_relay_with_db_mysql_ssl.sh \
longtermsecuredb/secure_relay_with_db_redis.sh \
restapi/secure_relay_secret.sh restapi/secure_relay_secret_with_db_mysql.sh \
restapi/secure_relay_secret.sh restapi/secure_relay_secret_with_db_redis.sh \
@@ -100,7 +103,7 @@ do-install:
.for f in ${_BIN_UTILS}
${INSTALL_PROGRAM} ${WRKSRC}/bin/turnutils_${f} ${STAGEDIR}${PREFIX}/bin/
.endfor
-.for f in ${MAN1}
+.for f in ${MANPAGES}
${INSTALL_MAN} ${WRKSRC}/man/man1/${f} ${STAGEDIR}${PREFIX}/man/man1/${f}
.endfor
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/net/turnserver/distinfo b/net/turnserver/distinfo
index baff0e3d8a4b..999c6f1f2eb9 100644
--- a/net/turnserver/distinfo
+++ b/net/turnserver/distinfo
@@ -1,4 +1,4 @@
-SHA256 (turnserver-3.2.2.5.tar.gz) = f615e1454e7d9fb4c7feb4e6c15d88c6809f3265501bfe771d493b44c954850e
-SIZE (turnserver-3.2.2.5.tar.gz) = 291987
+SHA256 (turnserver-3.2.4.4.tar.gz) = c10fac7b06247865cba7cf62af88fa8cc9824acb3fd6c4adbd52ed4f9d42a396
+SIZE (turnserver-3.2.4.4.tar.gz) = 305051
SHA256 (turn.extra.docs-2.0.0.1.tar.gz) = 3a86600fd0a30ce7aeb547e80402ce68ea9959f7dd58697e5b47fda6e33ab9ce
SIZE (turn.extra.docs-2.0.0.1.tar.gz) = 485379
diff --git a/net/turnserver/pkg-plist b/net/turnserver/pkg-plist
index 57774e007f75..fe62d5c31628 100644
--- a/net/turnserver/pkg-plist
+++ b/net/turnserver/pkg-plist
@@ -6,18 +6,25 @@ bin/turnutils_uclient
lib/libturnclient.a
etc/turnserver.conf.default
etc/turnuserdb.conf.default
+man/man1/turnserver.1.gz
+man/man1/turnadmin.1.gz
+man/man1/turnutils.1.gz
+man/man1/turnutils_peer.1.gz
+man/man1/turnutils_stunclient.1.gz
+man/man1/turnutils_uclient.1.gz
+man/man1/rfc5766-turn-server.1.gz
%%DATADIR%%/schema.sql
%%DATADIR%%/schema.userdb.redis
%%DATADIR%%/schema.stats.redis
%%DATADIR%%/testredisdbsetup.sh
-@dirrmtry %%DATADIR%%
+@dir %%DATADIR%%
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turnserver.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turnuserdb.conf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_client_cert.pem
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_client_pkey.pem
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_server_cert.pem
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/etc/turn_server_pkey.pem
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/etc
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/etc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/readme.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/peer.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/basic/relay.sh
@@ -45,6 +52,7 @@ etc/turnuserdb.conf.default
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/longtermsecure/secure_dos_attack.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/longtermsecuredb/secure_relay_with_db_psql.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/longtermsecuredb/secure_relay_with_db_mysql.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/longtermsecuredb/secure_relay_with_db_mysql_ssl.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/longtermsecuredb/secure_relay_with_db_redis.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/restapi/secure_relay_secret.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/restapi/secure_relay_secret_with_db_mysql.sh
@@ -57,22 +65,21 @@ etc/turnuserdb.conf.default
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/shorttermsecure/secure_relay_short_term_mech.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/selfloadbalance/secure_dos_attack.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/selfloadbalance/secure_relay.sh
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts/basic
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts/loadbalance
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts/longtermsecure
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts/longtermsecuredb
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts/restapi
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts/shorttermsecure
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts/selfloadbalance
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/scripts
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/basic
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/loadbalance
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/longtermsecure
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/longtermsecuredb
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/restapi
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/shorttermsecure
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts/selfloadbalance
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%/scripts
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%
include/turn/ns_turn_defs.h
include/turn/client/TurnMsgLib.h
include/turn/client/ns_turn_ioaddr.h
include/turn/client/ns_turn_msg.h
include/turn/client/ns_turn_msg_addr.h
include/turn/client/ns_turn_msg_defs.h
-@dirrmtry include/turn/client/
-@dirrmtry include/turn
+@dir include/turn/client
+@dir include/turn
@stopdaemon turnserver
-@dirrmtry include/turn/client