aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/rubygem-macaddr/Makefile9
-rw-r--r--net/rubygem-net-netrc/Makefile3
-rw-r--r--net/rubygem-openid/Makefile3
-rw-r--r--net/rubygem-twitter/Makefile1
-rw-r--r--net/rubygem-twitter4r/Makefile9
-rw-r--r--net/rubygem-yadis/Makefile3
6 files changed, 3 insertions, 25 deletions
diff --git a/net/rubygem-macaddr/Makefile b/net/rubygem-macaddr/Makefile
index f9e3bd757d88..2a3f6eecc736 100644
--- a/net/rubygem-macaddr/Makefile
+++ b/net/rubygem-macaddr/Makefile
@@ -15,13 +15,6 @@ COMMENT= Cross Platform Mac Address Determination for Ruby
USE_RUBY= yes
USE_RUBYGEMS= yes
-
-post-install:
- @${ECHO} ${GEM_CACHE} > ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/net/rubygem-net-netrc/Makefile b/net/rubygem-net-netrc/Makefile
index c93c659ee4ac..865a183b1c24 100644
--- a/net/rubygem-net-netrc/Makefile
+++ b/net/rubygem-net-netrc/Makefile
@@ -8,8 +8,7 @@
PORTNAME= net-netrc
PORTVERSION= 0.2.1
CATEGORIES= net rubygems
-MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= RF
MAINTAINER= don@na.rim.or.jp
COMMENT= Net::Netrc provides ftp(1)-style .netrc parsing
diff --git a/net/rubygem-openid/Makefile b/net/rubygem-openid/Makefile
index a3d5fa9913f6..809e04ef026a 100644
--- a/net/rubygem-openid/Makefile
+++ b/net/rubygem-openid/Makefile
@@ -22,7 +22,4 @@ USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
-post-install:
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -name "*~" -delete
-
.include <bsd.port.mk>
diff --git a/net/rubygem-twitter/Makefile b/net/rubygem-twitter/Makefile
index d1cf656b5f45..a6f79ed601d0 100644
--- a/net/rubygem-twitter/Makefile
+++ b/net/rubygem-twitter/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes
-GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/twitter
diff --git a/net/rubygem-twitter4r/Makefile b/net/rubygem-twitter4r/Makefile
index 4eca7d57f11b..0182d9b10c5d 100644
--- a/net/rubygem-twitter4r/Makefile
+++ b/net/rubygem-twitter4r/Makefile
@@ -19,13 +19,6 @@ RUN_DEPENDS= rubygem-json>=0.4.3:${PORTSDIR}/devel/rubygem-json
USE_RUBY= yes
USE_RUBYGEMS= yes
-
-post-install:
- @${ECHO} ${GEM_CACHE} > ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/net/rubygem-yadis/Makefile b/net/rubygem-yadis/Makefile
index c6db49decbc0..014442399c5a 100644
--- a/net/rubygem-yadis/Makefile
+++ b/net/rubygem-yadis/Makefile
@@ -19,7 +19,4 @@ USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
-post-install:
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -name "*~" -delete
-
.include <bsd.port.mk>