aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-aws-ses/Makefile23
-rw-r--r--net/rubygem-aws-ses/distinfo2
-rw-r--r--net/rubygem-aws-ses/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 42466ee80b58..0595100f2deb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1023,6 +1023,7 @@
SUBDIR += rubygem-amqp-utils
SUBDIR += rubygem-amqp067
SUBDIR += rubygem-aws-s3
+ SUBDIR += rubygem-aws-ses
SUBDIR += rubygem-bunny
SUBDIR += rubygem-bunny060
SUBDIR += rubygem-connection_pool
diff --git a/net/rubygem-aws-ses/Makefile b/net/rubygem-aws-ses/Makefile
new file mode 100644
index 000000000000..fb66667156e0
--- /dev/null
+++ b/net/rubygem-aws-ses/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aws-ses
+PORTVERSION= 0.6.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Client library for REST API of Amazon SES
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-builder32>=0:${PORTSDIR}/devel/rubygem-builder32 \
+ rubygem-mail>=2.2.5:${PORTSDIR}/mail/rubygem-mail \
+ rubygem-mime-types>=0:${PORTSDIR}/misc/rubygem-mime-types \
+ rubygem-xml-simple>=0:${PORTSDIR}/textproc/rubygem-xml-simple
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-aws-ses/distinfo b/net/rubygem-aws-ses/distinfo
new file mode 100644
index 000000000000..7982534efcae
--- /dev/null
+++ b/net/rubygem-aws-ses/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/aws-ses-0.6.0.gem) = ee9601369f47c9dbd3156341fdee3f21c2c2faa68ed2f429e9a1c23ec4645a37
+SIZE (rubygem/aws-ses-0.6.0.gem) = 21504
diff --git a/net/rubygem-aws-ses/pkg-descr b/net/rubygem-aws-ses/pkg-descr
new file mode 100644
index 000000000000..fba6f77adc1b
--- /dev/null
+++ b/net/rubygem-aws-ses/pkg-descr
@@ -0,0 +1,6 @@
+AWS::SES is a Ruby library for Amazon's Simple Email Service's REST API [1].
+
+[1] https://aws.amazon.com/ses/
+
+WWW: https://github.com/drewblas/aws-ses
+RG: https://rubygems.org/gems/aws-ses