aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Todoist/Makefile25
-rw-r--r--net/p5-Net-Todoist/distinfo2
-rw-r--r--net/p5-Net-Todoist/pkg-descr3
-rw-r--r--net/p5-Net-Todoist/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index dfac989e9042..0c05a2af26e4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -644,6 +644,7 @@
SUBDIR += p5-Net-Telnet
SUBDIR += p5-Net-Telnet-Netscreen
SUBDIR += p5-Net-TiVo
+ SUBDIR += p5-Net-Todoist
SUBDIR += p5-Net-Traceroute
SUBDIR += p5-Net-Traceroute-PurePerl
SUBDIR += p5-Net-Traceroute6
diff --git a/net/p5-Net-Todoist/Makefile b/net/p5-Net-Todoist/Makefile
new file mode 100644
index 000000000000..c1e6fa52ebc4
--- /dev/null
+++ b/net/p5-Net-Todoist/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-Todoist
+# Date created: 2010-11-06
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Todoist
+PORTVERSION= 0.03
+CATEGORIES= net www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Todoist API
+
+RUN_DEPENDS= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Todoist.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Todoist/distinfo b/net/p5-Net-Todoist/distinfo
new file mode 100644
index 000000000000..acfa4b0fef65
--- /dev/null
+++ b/net/p5-Net-Todoist/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Todoist-0.03.tar.gz) = e4422f9d220b1abc90bb468a7fff87ea7461fb67bdbba58bd86d88b240cf8dd8
+SIZE (Net-Todoist-0.03.tar.gz) = 12311
diff --git a/net/p5-Net-Todoist/pkg-descr b/net/p5-Net-Todoist/pkg-descr
new file mode 100644
index 000000000000..ec78134b7d7f
--- /dev/null
+++ b/net/p5-Net-Todoist/pkg-descr
@@ -0,0 +1,3 @@
+Todoist API. Read http://todoist.com/API/help for more details.
+
+WWW: http://search.cpan.org/dist/Net-Todoist/
diff --git a/net/p5-Net-Todoist/pkg-plist b/net/p5-Net-Todoist/pkg-plist
new file mode 100644
index 000000000000..4bbc7ceae848
--- /dev/null
+++ b/net/p5-Net-Todoist/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Todoist/.packlist
+%%SITE_PERL%%/Net/Todoist.pm
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Todoist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net